Very odd text selection behaviour

An
Anael
Posts: 3
Joined: Fri Apr 09, 2010 2:36 pm

Tue Dec 26, 2017 12:55 pm Post

Hello,

this is a very specific and odd glitch:

When I'm typing a document within Scrivener 3 and I manually select text using option + shift + left arrow key, the last letter of the last finished line doesn't get selected. When I hit "delete", the character remains at the end of the line.
(For example, if I was to select text in this post in that way, the "d" of the "the last letter [...] " line would remain.

I've tested it in other softwares and the behaviour isn't replicated.
I've tested it in Scrivener with option + shift + up arrow key and it isn't replicated.
I've tested it in Scrivener with shift + left arrow key and it isn't replicated.
This didn't happen on Scrivener 2.

It only happens with option + shift + left and it only does it with the last character of the last finished line and only if said line reaches the end of the right margin (i.e. not with a forced line break using the Return key).

I understand that this is a very specific request but this is a combination of keys I use a lot when I edit as I'm composing and it really weighs on my process.

I'm not sure if you can isolate what produces this glitch but if you could patch it, that would be AWESOME.

I can provide screenshots if it helps.

[edit] Formatting

Jo
Jolanth Szatmary
Posts: 161
Joined: Sat Oct 06, 2007 9:58 am
Platform: Mac
Location: Berlin, Germany

Wed Dec 27, 2017 8:47 am Post

Hi,

I just tried to replicate this, everythings works as it should on my system. Have you updated to High Sierra? I'm still using Sierra, as I've heard of many glitches with with text selection, text dragging, etc. in High Sierra. Still strange that this behaviour can't be replicated in other Apps. Have you tried TextEdit?

Best,

J

An
Anael
Posts: 3
Joined: Fri Apr 09, 2010 2:36 pm

Tue Jan 02, 2018 12:11 pm Post

Hi Jo.
Thank you for answering!
No, I'm still in Sierra and, yes, I've tried in TextEdit and it doesn't replicate this behaviour although it is systematic in Scrivener.
A.

User avatar
Bridey
Posts: 390
Joined: Wed Nov 22, 2017 2:24 pm
Platform: Mac

Tue Jan 02, 2018 12:41 pm Post

Doesn't help you, but I don't have the same problem using Scrivener 3.0.1 (966) on High Sierra, macOS 10.13.3 (17D25b).

User avatar
lunk
Posts: 2712
Joined: Wed Aug 21, 2013 4:24 pm
Platform: Mac + iOS
Location: Sweden 64° N

Tue Jan 02, 2018 1:06 pm Post

On my Mac it is the alt key that has the text option, and the Apple key has the text command. If I press shift-option-left arrow I select one word to the left, nothing else. Using shift-command-left arrow selects from the cursor position to the beginning of the line, irrespective of where the cursor is positioned and without error.

Is the key combination you talk about really shift-option-left, not shift-command-left?
I am a user, writing non-fiction and science, using:
* Mac Scrivener 3 on a Macbook 12”, MacBook Pro 13”, and iMac 27”, all running the latest MacOS
* iOS Scrivener 1 on an iPhone 8, iPad Air 9.7”, and iPad Pro 12.9”, all running the latest iOS

pa
paolinobra
Posts: 13
Joined: Fri Oct 02, 2015 6:54 am
Platform: Mac

Thu Mar 01, 2018 3:31 pm Post

Hi!
The same for me, but not always. Sometimes happens, sometimes not. Very odd!

It never happens with mouse selection, with keyboard I can't explain the different situation.
The last letter is ignored by selection, but it can be included coming back.
Let's explain.

Starting selecting with option + shift + left, the last letter is ignored:
before.jpeg
before.jpeg (177.41 KiB) Viewed 1229 times


Coming back with option + shift + right, the last letter is considered:
after 1.jpeg
after 1.jpeg (127.62 KiB) Viewed 1229 times


Forward again with with option + shift + left, all is ok:
after 2.jpeg
after 2.jpeg (121.15 KiB) Viewed 1229 times


:?:

pa
paolinobra
Posts: 13
Joined: Fri Oct 02, 2015 6:54 am
Platform: Mac

Thu Mar 01, 2018 3:34 pm Post

The situation can change during the same text and I don't know why.

In some lines there is the odd behaviour:
another case.jpeg
another case.jpeg (194.7 KiB) Viewed 1227 times

case 3.jpeg
case 3.jpeg (150.35 KiB) Viewed 1227 times


In some lines no!
different one.jpeg
different one.jpeg (149.5 KiB) Viewed 1227 times


Bye!

User avatar
KB
Site Admin
Posts: 20108
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Thu Mar 01, 2018 3:47 pm Post

This is in fact a known bug in macOS - it's a bug in Apple's text system on which Scrivener is built, and the only way for me to fix it would be to try to rewrite all of the macOS text selection routines from scratch. The same bug can be reproduced in TextEdit. I reported it to Apple on 6th December 2017 and it is logged in their system as bug ID #35880394. Sadly, I don't expect them to fix it any time soon, as they fix very, very few text system bugs, even major ones.
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

pa
paolinobra
Posts: 13
Joined: Fri Oct 02, 2015 6:54 am
Platform: Mac

Thu Mar 01, 2018 4:06 pm Post

What a pity Apple's behaviour ...
Thank you Keith!
Paolo