empty document forgets assigned style

da
dave8118
Posts: 9
Joined: Sun Nov 09, 2008 12:51 am
Platform: Mac

Thu Dec 21, 2017 5:57 pm Post

Documents (as in, a single document in the Binder) without any text in them don't remember the styles assigned to them.

I'm noticing this in Scrivener for Mac 3.0.1, running 10.13.2, on a macbook pro, with a document that syncs via dropbox.

Steps to reproduce:
1. Create a new document in the binder.
2. Click in the text field, but don't type anything.
3. Select a style from the dropdown style list.
4. Think "oh wait, I need to finish something else before I write this!" Don't type anything in the new document.
5. Click to another document in the binder.
6. Click back into the new document that you created. Click in the text field.
7. Note that the text field has the default no-style formatting, not whatever style you assigned it.

I see the same behavior if I type into the document in step 4 and then delete the text before clicking away—it seems that whenever you click away from a blank document, it reverts to the default formatting.

I expected the empty document to remember its style when I clicked back into it. (It's my recollection that Scrivener 2 did remember the formatting for empty documents, but I'm not 100% confident of that. Maybe 80% confident.)

Not the end of the world, but a little annoying!

On a side note, it's a little odd that when you adjust the "main text formatting for new documents" in preferences (which is the formatting that the blank document in the above script reverts to), there isn't an option to select from the available styles in addition to manually adjusting the formatting.

User avatar
KB
Site Admin
Posts: 20506
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Thu Dec 21, 2017 7:24 pm Post

Hi,

This is expected behaviour. Empty documents always use default formatting when you return to them.

As for the Preferences, it is recommended that you do not use a style for your body text but stick to "No Style", which is why you cannot choose styles there. In Scrivener, it is far better only to use styles for text that is different from the main body of the text, otherwise you will find Compile more difficult.

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."