Full Screen Mode with Typewriter Scrolling and Inline Annotations

se
se1961
Posts: 140
Joined: Tue Jul 05, 2011 8:00 pm
Platform: Mac

Tue Dec 12, 2017 1:24 pm Post

You can see from the title that this is is quite specific. :wink: I often write a long passage, and then scroll back up to the beginning and mark the bits I like as "inline annotation." Then I export all the annotations as a separate document. I've been doing this for years in Scrivener. Now (Scrivener 3, High Sierra) when I mark text with inline annotations, the focus jumps to the end of the document. This makes it impossible to mark up long documents-- each time I mark an inline annotation, the focus jumps to the end of the document, and I have to scroll back up to the top, looking for the last annotation I made. It only happens in full screen mode, and only when typewriter scrolling is on. I have turned typewriter scrolling off for now, but would prefer to be able to use it along with inline annotations, as I have in the past. :)

br
brookter
Posts: 1718
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Tue Dec 12, 2017 1:37 pm Post

There's a setting; Preferences > Editing > Options > Typewriter scrolling always jumps to scroll line.

Try turning that on and see if the behaviour changes (it does for me...).

se
se1961
Posts: 140
Joined: Tue Jul 05, 2011 8:00 pm
Platform: Mac

Tue Dec 12, 2017 1:44 pm Post

It WORKED!!!! Thank you! I never would have noticed it without your help-- even after I read your post, I thought you must be mistaken, because (to me) "always jump to scroll line" seemed to suggest that it would jump to the end of the document. Thank you thank you thank you!

br
brookter
Posts: 1718
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Tue Dec 12, 2017 1:47 pm Post

No problem -- glad it helped!

It's one of the clever additions in V3.

In V2 you were either in writing mode (typewriter scrolling on) or editing mode (scrolling off). This setting allows you to combine the two while retaining the old behaviour if you want to.

User avatar
KB
Site Admin
Posts: 20218
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Tue Dec 12, 2017 1:54 pm Post

When you first opened full screen mode in Scrivener 3, you should have seen a panel appear blocking full screen mode and explaining typewriter scrolling behaviour. Out of interest, did you never see this panel, or did you dismiss it without reading it (perhaps because you assumed it was for new users who had never used typewriter scrolling before)? I'm just trying to work out if there is a bug whereby this panel isn't appearing or if I need to reword the title to try to encourage existing users to read it. :)

Thanks and all the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

se
se1961
Posts: 140
Joined: Tue Jul 05, 2011 8:00 pm
Platform: Mac

Tue Dec 12, 2017 2:22 pm Post

Absolutely saw it, loud and clear. Dismissed without reading, telling myself that I could always look it up later if I needed to. What harm could it cause? :oops:

FWIW, I do think different wording might help capture the attention of other impatient users. And I definitely think some clarification around "jump to scroll point" would help. Although now there is this handy thread for people to find when they are searching for answers.

Fun fact: I had typewriter mode turned off in Scrivener 2 (and in Scrivener 1 for Windows) because I found it fiddly. Hard to explain, just that sometimes the screen jumped unpredictably, and I didn't think it was worth the effort to the keep the text centered. It works beautifully in Scrivener 3.