Weird behavior on Composer mode

ch
chaarrliie
Posts: 8
Joined: Wed Nov 15, 2017 3:32 pm
Platform: Mac + iOS

Mon Dec 11, 2017 6:12 pm Post

Hi,

When I am on composer mode (fullscreen), if I receive a notification, say for an email for instance, and I click on it in order to see it in the mail app, then Scrivener quits the composer mode and open the email fullscreen instead.

Is there a way to change that? Shouldn't it just switch to another space instead of killing completely the composer mode?

N.B: this is also happening when I activate the composer mode while the Scrivener app was not previously in MacOS fullscreen mode.

Thanks :)

User avatar
kewms
Posts: 4135
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Mon Dec 11, 2017 6:40 pm Post

Composition mode does not create another desktop, it pulls a "curtain" over the one where it is invoked.

(Why? So that you can fade the background to see notes and other research materials if needed.)

So when you click on another window, Scrivener assumes that bringing that window to the front (and therefore closing Composition mode) is exactly what you wanted to do.

Katherine
Scrivener Support Team

ch
chaarrliie
Posts: 8
Joined: Wed Nov 15, 2017 3:32 pm
Platform: Mac + iOS

Mon Dec 11, 2017 6:50 pm Post

Hmm, OK, but why does that put this newly invoked window in fullscreen mode?

With my example, Mail was not in fullscreen either, but the mail I opened by clicking on the notification was put on fullscreen instead of the composition mode of Scrivener... Is that the intended behavior?

While we are on the topic of composition mode, I've got two other questions, if you don't mind;

1. You say that composition mode allows you to fade the background in order to see notes? How so?
All I can do is open the inspector, go to another file, or fade the sheet in order to see the background, but I don't know what you mean about fading the background itself :)

2. No matter which setting I choose for the composition mode (main screen, actual screen, etc), if my Scrivener app was already in fullscreen mode, another desktop is created when I enter composition mode.
Which is new and great, since I can now switch from my text in composition mode to the scrivener app and browse my binder without interfering with the text in the other space.
However:
- the position of the two spaces are regularly inverted. Do you know what causes that?
- is there a way to only have one space in composition mode, even if the app was previously on fullscreen?

Thanks again for the clarifications :)

User avatar
AmberV
Posts: 22425
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Tue Dec 12, 2017 11:58 am Post

You say that composition mode allows you to fade the background in order to see notes? How so?

If you have the project window is in full screen then that capability doesn’t work because as you note composition goes to a new space. The only background you’ll see is the desktop image. But for the record, the slider is in the bottom-right of the screen when you pull the mouse down and pop up the control panel.

With my example, Mail was not in fullscreen either, but the mail I opened by clicking on the notification was put on fullscreen instead of the composition mode of Scrivener… Is that the intended behavior?

I couldn’t say, that’s how your Mac works, not Scrivener. It seems odd to me, given how the concept of full screen is intended to isolate rather than multitask, but full screen is full of quirks so that might be one of them. That answer goes for some of the other questions as well, such as where the new Space is created in a spatial sense from the first—Scrivener has no control over Mission Control.

There is no way to overlap composition with full screen. I believe that change was made to avoid some of the aforementioned quirks.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

ch
chaarrliie
Posts: 8
Joined: Wed Nov 15, 2017 3:32 pm
Platform: Mac + iOS

Tue Dec 12, 2017 12:06 pm Post

OK, thanks for your answers...
It seemed a bit buggy to me because the order of the spaces between the main Scrivener window and the Composition mode changed each time I switched spaces to use another app.

AmberV wrote:If you have the project window is in full screen then that capability doesn’t work because as you note composition goes to a new space. The only background you’ll see is the desktop image. But for the record, the slider is in the bottom-right of the screen when you pull the mouse down and pop up the control panel.


That's really weird: even if I deliberately leave Scrivener in the windowed mode (so not fullscreen), when I enter the Composition mode, the only thing the slider does on the bottom-right is to fade the sheet so I can see the background set in the settings (plain color or texture). I can never see the Scrivener window underneath. Maybe it is something to set somewhere in the settings? I haven't found out where though...

Thanks again :wink:

User avatar
AmberV
Posts: 22425
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Tue Dec 12, 2017 12:15 pm Post

It seemed a bit buggy to me because the order of the spaces between the main Scrivener window and the Composition mode changed each time I switched spaces to use another app.

That sounds like a default macOS option that I always turn off, in the System Preferences: Mission Control panel, “Automatically rearrange Spaces based on most recent use”.

Do you have the option ticked to open Composition mode on a new Space? Another one to check is whether the main project window will be hidden (which it is by default for performance reasons).

That’s really weird: even if I deliberately leave Scrivener in the windowed mode (so not fullscreen), when I enter the Composition mode, the only thing the slider does on the bottom-right is to fade the sheet so I can see the background set in the settings (plain color or texture).

Oh yes, I should have mentioned that the slider will read “Background Fade” when you can do this. If it reads “Paper Fade” that means you have a background texture or backdrop set in the project. It only works if the background around the “paper” is a solid colour. That is set in the Appearance pane, the backdrop is in Backdrop Images, in Project/Project Settings....
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

ch
chaarrliie
Posts: 8
Joined: Wed Nov 15, 2017 3:32 pm
Platform: Mac + iOS

Tue Dec 12, 2017 3:16 pm Post

OK, got it, thanks!

I'm so sorry, but after reading your last answer I wanted to test that myself, so I went in the Scrivener Appearance settings tab and reset the background to the default texture (black - sorry for the French UI)
https://www.dropbox.com/s/mok7u707hlhu3 ... 8.png?dl=0

But, then, when I entered into the Composition mode again, the background didn't change:
https://www.dropbox.com/s/mrw6yapqpiv40 ... 1.png?dl=0

I tried quitting and relaunching Scrivener, changing for another background or another texture color, but nothing changes... Any idea why or how to fix this?

Thanks again!

User avatar
AmberV
Posts: 22425
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Tue Dec 12, 2017 4:08 pm Post

No no, my apologies, I was not clear enough before. In your second screenshot you have a photograph. Scrivener cannot blend your photograph with the windows underneath it. The photograph has to be removed to blend.
  1. Projet/Paramétres du project...
  2. Click on the “Images d’arriére-plan” section.
  3. Select Aucun fond.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

ch
chaarrliie
Posts: 8
Joined: Wed Nov 15, 2017 3:32 pm
Platform: Mac + iOS

Tue Dec 12, 2017 4:13 pm Post

Ah! Yes, sorry, I had forgotten that Scrivener 3 now allows that, I was still used to the Scrivener 2 settings where you had to go through the Composition mode background setting to change the background ^^

Now I got it, thanks ;)