Activation issue attempting to use both Version 2 and Version 3

User avatar
thomasalmy
Posts: 13
Joined: Tue Nov 21, 2017 11:50 pm
Platform: Mac
Location: Oregon, USA
Contact:

Wed Nov 22, 2017 12:07 am Post

I'm running both side by side to work out the differences, but I've discovered and issue. Each time I launch the alternate version I get a "Product activation required" dialog. Opening the same version repeatedly has no problems.

Additionally, sometimes opening version 2 after 3 will cause "Unknown activation error Product activation for Scrivener failed with error: -2003"

Thinking that the problem might be related to a conflict in the license numbers and reading somewhere that a version 3 license will also work with version 2 I attempted to deactivate version 2 and reregistering with the version 3 license. However this gives the error dialog "Product deactivation for Scrivener encountered an error."

The problem exists on both my desktop iMac and my MacBookPro so I suspect it is a general problem. Not serious since both versions do run as registered but it is annoying.

User avatar
Silverdragon
Posts: 327
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac + iOS
Contact:

Wed Nov 22, 2017 2:45 am Post

I'm experiencing this exact same... minor irritation, to be honest. ;-)
So you know where I'm coming from:
• I'm a user, not an L&L employee.
• Mac Scrivener 2.9 & 3.0.0, MacBook Air 11, MacOS 10.12.6 (Sierra)
• iOS Scrivener 1.1.5, iPhone 6s, iPad Air 2, iOS 11.2

User avatar
KB
Site Admin
Posts: 19190
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Wed Nov 22, 2017 12:03 pm Post

I can reproduce this, although I'm not sure of the cause because both versions use completely different validation details. I'm looking into it.
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

User avatar
KB
Site Admin
Posts: 19190
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Wed Nov 22, 2017 5:17 pm Post

After a fun five hours on this, I am no closer to working out the underlying problem, so I have emailed eSellerate for some insight into the matter. I have a feeling it is to do with the older eSellerate engine that Scrivener 2 uses, but I cannot understand how the two serial numbers would interfere with one another.

I do have a solution for you, though:

1. Download Scrivener 2.9 (follow the "Download an Older Version" link on our Downloads page). If you've already downloaded it, re-download, because I've made an edit to the code that will make deactivation easier.

2. Replace your existing version of Scrivener 2 with Scrivener 2.9.

3. Launch Scrivener 2.9.

4. Go to Scrivener > Registration... and deactivate your licence. Don't worry if you see a deactivation error. I've made it so that it will remove your serial number details anyway.

5. Quit and relaunch Scrivener 2.9. (This part shouldn't be necessary, but it sometimes helps avoid activation issues.)

6. Go to Scrivener > Registration... and enter your Scrivener 3 user name and serial number.

Scrivener 2.9 can be activated with a Scrivener 3 serial number, and doing this avoids whatever problems are going on with trying to run concurrent activations of two versions, because now the activation is the same for both.

I've tested this a few times and it has solved the issue for me, but let me know how it goes.

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

au
auxbuss
Posts: 87
Joined: Mon Nov 30, 2015 9:50 pm
Platform: Mac
Contact:

Wed Nov 22, 2017 7:54 pm Post

That worked for me.

ps
pseingalt
Posts: 103
Joined: Sun Nov 07, 2010 3:14 am
Platform: Mac

Thu Nov 23, 2017 4:27 pm Post

Same problem.
Deleting v2.x for v2.9 will wipe out custom settings, recent documents, etc.
I certainly don't want to remove v.2 until I have the time to learn v3. Apparently the time required to do so, if my posts and the posts of others of the fora are accurate.
When it rains it pours.

sh
shorn
Posts: 63
Joined: Mon Jul 10, 2006 4:19 pm
Platform: Mac
Location: Montreal, Quebec, Canada
Contact:

Thu Nov 23, 2017 5:00 pm Post

This worked for me.

I don't know about custom settings, but all my recent documents are still there, unchanged.

User avatar
thomasalmy
Posts: 13
Joined: Tue Nov 21, 2017 11:50 pm
Platform: Mac
Location: Oregon, USA
Contact:

Thu Nov 23, 2017 6:42 pm Post

Thanks. It's now working.

Online
cl
cliophoto
Posts: 5
Joined: Wed Jan 19, 2011 9:04 pm
Platform: Mac + iOS
Location: Summer Southern Ontario. Where it is warm for winter in Southern USA.

Fri Nov 24, 2017 2:42 am Post

Used this method and it fixed the problem for me as well.

Thanks
Phil

User avatar
nontroppo
Posts: 755
Joined: Mon Mar 05, 2007 5:22 pm
Platform: Mac
Location: Airstrip One

Fri Nov 24, 2017 3:21 am Post

Worked for me too, thanks!

User avatar
devinganger
Posts: 903
Joined: Sat Nov 06, 2010 1:55 pm
Platform: Mac + Windows
Location: Monroe, WA USA
Contact:

Sat Nov 25, 2017 6:49 am Post

pseingalt wrote:Same problem.
Deleting v2.x for v2.9 will wipe out custom settings, recent documents, etc.
I certainly don't want to remove v.2 until I have the time to learn v3. Apparently the time required to do so, if my posts and the posts of others of the fora are accurate.
When it rains it pours.


It doesn't say delete. It says "replace". Install 2.9 Scrivener.app right over the top of the existing 2.8.1 Scrivener.app. Since it's Scrivener 2.8.1. that now understands the 3.x license, it will preserve the rest of the 2.x settings. You then de-activate, then re-activate.
--
Devin L. Ganger
Devin on Earth: http://www.devinonearth.com/
Plotter on the streets, pantser in the sheets

ps
pseingalt
Posts: 103
Joined: Sun Nov 07, 2010 3:14 am
Platform: Mac

Sat Nov 25, 2017 7:35 am Post

"Overwrite" deletes the existing program, leaving an unopened program with new settings. I'm not willing to risk overwriting an installation in the hope that installation's settings will be preserved. On too many occasions these have been lost. I'll have to go through the program and see if I can export or save these manually before risking replacing the existing program. To complicate matters, there is v2 app store and v2 download with two separate licenses as well as the new v3 upgrade.

User avatar
KB
Site Admin
Posts: 19190
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Sat Nov 25, 2017 12:37 pm Post

Overwriting Scrivener 2.8.1 with Scrivener 2.9 will not - and cannot - overwrite any settings given that all Preferences etc are stored elsewhere. It will no more get rid of your settings than updating from 2.8 to 2.8.1 lost settings (it didn't). Updating to Scrivener 3 is a different story because it is a different app with a different internal identifier and so does not use Scrivener 2's settings.
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

User avatar
Simon T
Posts: 63
Joined: Sat Oct 25, 2008 6:04 pm
Platform: Mac + iOS
Location: UK
Contact:

Sun Dec 03, 2017 8:20 am Post

Just to confirm, I too have the initial problem with both versions of Scrivener (2 &3) requiring product activation on first start-up. I haven't tried the fix yet, but I can probably live with it for now, and hope to migrate fully to 3 fairly soon.