MulitMarkdown issue

to
tobyr21
Posts: 11
Joined: Tue Jan 17, 2017 10:49 pm
Platform: Mac

Sun Jan 14, 2018 2:23 am Post

My attempt to use markdowns in scriv 3 produced a total mess in my complied output.

I am using scrivener 3.01 on my Mac. In Scriv 2, I used asterisks to get italicized text, and everything looked fine.
After I updated to Scriv 3, my compile worked correctly except that my use of asterisks for italics was ignored. (I saw asterisks in my output.)

I am compiling Manuscript (times) for MS word. When I turn on the compile option to Convert Multimarkdown to rich text in notes and text, each section of my Scriv project becomes one gigantic paragraph. (And markdown works; I get the desired italics.)
I had no trouble turning markdown on in scriv 2. What am I doing wrong? Where in scriv 3 is the option to just observe my asterisk markdowns without turning lots of short dialog into one gigantic paragraph?
- tobias d. robison

Thanks in advance for your help.

User avatar
Bridey
Posts: 390
Joined: Wed Nov 22, 2017 2:24 pm
Platform: Mac

Sun Jan 14, 2018 7:56 am Post

Hello.

Do you only have a single return between paragraphs? MD/MMD expects two returns to create a full blank line.

https://daringfireball.net/projects/markdown/syntax#p

Paras.jpg
Paras.jpg (175.73 KiB) Viewed 2637 times


If you do only have a single return (no blank line), do a test by adding additional returns to your opening paragraphs and trying another compile.

If that works as you need it to, you can search for single returns (OPTION RETURN) and replace them with double returns (OPTION RETURN x 2) throughout your project.
Last edited by Bridey on Sun Jan 14, 2018 4:44 pm, edited 1 time in total.

to
tobyr21
Posts: 11
Joined: Tue Jan 17, 2017 10:49 pm
Platform: Mac

Sun Jan 14, 2018 2:56 pm Post

Before I get angry, I will politely request that a feature be added to scriv 3 that enables its use of markdowns to be the same as it was in scriv 2. Please.

This is an amazing difference between scriv 2 and scriv 3! Apparently, I'm expected to go through all of the sections of all of my projects, doubling the end-lines after every paragraph. And will that change the way the text looks onscreen while I'm editing? Adding lots of white space, so that I see less text onscreen?

I'm outraged that this issue snuck up on me, with no compatibility fix built in to scriv 3. There are real advantages to using markdown, but I'm going to go through all my projects and replace those asterisks with italicized text. Screw the multimarkdowns! They are now more trouble than they are worth.

I will appreciate additional comments, and I apologize for misspelling the title of this thread.

User avatar
Bridey
Posts: 390
Joined: Wed Nov 22, 2017 2:24 pm
Platform: Mac

Sun Jan 14, 2018 4:48 pm Post

tobyr21 wrote:I apologize for misspelling the title of this thread.


You *should* be able to edit the original post and correct the title, if you want to.

And an explanation from a member of the support team:

viewtopic.php?p=253916#p253916

User avatar
AmberV
Posts: 22044
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Sun Jan 14, 2018 5:20 pm Post

You might be able to get away with adding a Replacement to your compile settings that converts one carriage return with two, meaning no text in the editor changes. Do proof around areas that might suffer from that kind of treatment though. Lists, tables, etc.

I have to say though, we never thought there would be anyone that really wanted such a limited conversion. Most people we've spoken with requested Scrivener do full conversion like it currently does---hence the change. Sorry you got hit with the downside of those feature requests!
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
Bridey
Posts: 390
Joined: Wed Nov 22, 2017 2:24 pm
Platform: Mac

Sun Jan 14, 2018 5:24 pm Post

I was just going to say...

If using a MultiMarkdown-based format during compile, you can use a replacement to replace a single return with a double return (as Ioa says in the post above). However, this doesn’t work for non-MultiMarkdown-based compiles, such as PDF or simple RTF.

If you want PDF, docx, etc output (you said you were compiling to Word), you need to include the double returns in the editor.

User avatar
Bridey
Posts: 390
Joined: Wed Nov 22, 2017 2:24 pm
Platform: Mac

Sun Jan 14, 2018 5:38 pm Post

AmberV wrote:You might be able to get away with adding a Replacement to your compile settings that converts one carriage return with two, meaning no text in the editor changes.


Hello, Ioa.

That doesn't work when compiling to Word, PDF, simple RTF, etc. Only if doing a MultiMarkdown to ... compile. Or am I missing a trick?

User avatar
AmberV
Posts: 22044
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Sun Jan 14, 2018 5:47 pm Post

Hmm, I’m not sure why that isn’t working, unless perhaps Replacements are being run after the MMD conversion is already done—I bet that’s what it is. If so I can’t think of any other approach to make things easier than original source revision. The other trick, converting paragraphs spacing to literal whitespace, only works with plain-text output formats.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
Bridey
Posts: 390
Joined: Wed Nov 22, 2017 2:24 pm
Platform: Mac

Sun Jan 14, 2018 7:18 pm Post

AmberV wrote:Hmm, I’m not sure why that isn’t working, unless perhaps Replacements are being run after the MMD conversion is already done—I bet that’s what it is. If so I can’t think of any other approach to make things easier than original source revision. The other trick, converting paragraphs spacing to literal whitespace, only works with plain-text output formats.


Yes, my thoughts exactly: the sequence of the compile process. But, as you say, there are workarounds, and the S3 MMD compile is definitely more thewy.

to
tobyr21
Posts: 11
Joined: Tue Jan 17, 2017 10:49 pm
Platform: Mac

Mon Jan 15, 2018 3:26 am Post

I want to thank everyone for this dialog, which helped me to feel pretty good about removing all the asterisks from the book I am working on, using instead actual italics and bolding. It took me about 70 minutes (I've had much worse disastrous wastes of time as a software developer), and now I can ignore all issues related to MultiMarkdown.

Again, thanks.

ro
rocsandford
Posts: 1
Joined: Fri Jan 26, 2018 4:42 pm
Platform: Mac

Fri Jan 26, 2018 4:49 pm Post

I have a related issue in scrivener 3.0.1, which I have not been able to find a solution to in the manual. Apologies if it is there and I have missed it.

If I select the option *convert rich text to multimarkdown* when I compile, my rich text italics are output correctly, but not my multimarkdown italics. If I don't select *convert rich text to multimarkdown,* then my multimarkdown italics output correctly, but not the rtf ones.

In scrivener 2 there was an option to convert rtf to mmd in the editor, but I think this may have been removed, hence the mix of rtf and mmd markup of italics.

I could manually convert all rich text to mmd, but would rather an automated version given the scale or the problem.

Any help would be much appreciated, thank you!

User avatar
AmberV
Posts: 22044
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Fri Jan 26, 2018 5:03 pm Post

In scrivener 2 there was an option to convert rtf to mmd in the editor, but I think this may have been removed, hence the mix of rtf and mmd markup of italics.


Yes, that option was removed now that there is one that does full conversion, as discussed more in-depth above.

Do note the Edit ▸ Copy Special ▸ Copy as Markdown menu command, which ought to help significantly. It’s worth noting that it uses the same engine as the compiler checkbox does—so only use that on the chunks of text that are pure RTF.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
rdale
Posts: 1246
Joined: Tue Jul 14, 2015 1:07 pm
Platform: Mac, Win + iOS
Location: St. Louis, MO
Contact:

Fri Jan 26, 2018 5:22 pm Post

AmberV wrote:You might be able to get away with adding a Replacement to your compile settings that converts one carriage return with two, meaning no text in the editor changes. Do proof around areas that might suffer from that kind of treatment though. Lists, tables, etc.

Has Keith ever considered enhancing the replacements feature to optionally designate replacements to only work on a particular style (or unstyled text)? That way, lists and other specially formatted text could be marked with a style to protect them (and also to format them nicely in the editor). A drop-down list of "no style" + all the project's current set of styles could be added to replacements tab, so that in this case, 'no style' text could replace all newlines with two newlines,but text marked with any other paragraph style would not have extra newline characters added to them.

I imagine such a feature enhancement would apply to other processes other than converting partially MMD'd text... though nothing's coming to mind right now.
FKA: robertdguthrie
AKA: R Dale Guthrie, Robert, Mr. Obscure, and "Oh, it's you again".

User avatar
AmberV
Posts: 22044
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Fri Jan 26, 2018 5:28 pm Post

Ha! Scoped replacements would be great, I would certainly make use of them. However I suspect that given what a massive snarl of spaghetti replacements are, it might not be a suggestion that goes down favourably. :mrgreen:
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
rdale
Posts: 1246
Joined: Tue Jul 14, 2015 1:07 pm
Platform: Mac, Win + iOS
Location: St. Louis, MO
Contact:

Fri Jan 26, 2018 6:40 pm Post

AmberV wrote:Ha! Scoped replacements would be great, I would certainly make use of them. However I suspect that given what a massive snarl of spaghetti replacements are, it might not be a suggestion that goes down favourably. :mrgreen:

Lucky for me, I've yet to need such an enhancement, so I won't be the one asking for it. :twisted:
FKA: robertdguthrie
AKA: R Dale Guthrie, Robert, Mr. Obscure, and "Oh, it's you again".