LaTeX header and begin document components missing in compile

User avatar
AmberV
Posts: 20613
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Sat Dec 02, 2017 7:06 pm Post

I’d appreciate it, as it’s the same every time for me! Even deleting the whole tex directory and re-compiling still appends the colon onto it.

I wouldn’t think anything related to files would be involved. Scrivener, and for that matter MultiMarkdown itself, don’t really care much about what .tex files you have when typing in your own include codes or using the custom settings. It probably has more to do with some variation of syntax—are hyphens used, spaces in key names, etc.

Emma: maybe if you could export your format to a file and attach it I could have a look at it and see if I get the colons as well? Right-click on the format in the compile overview screen to do so (and feel free to PM me if you don’t want it shared publicly).

napaxton: I think your settings look good, but I’d double-check the placement of the “Insert Project Metadata Here” row. Perhaps in MMD6 it doesn’t matter, but it used to be important that stuff like “Title” and “Author” fall between what is now the ‘latex leader’ and before what is now the ‘latex begin’ keys.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

na
napaxton
Posts: 43
Joined: Wed Jan 19, 2011 5:42 pm
Platform: Mac

Sat Dec 02, 2017 11:31 pm Post

AmberV wrote:
napaxton: I think your settings look good, but I’d double-check the placement of the “Insert Project Metadata Here” row. Perhaps in MMD6 it doesn’t matter, but it used to be important that stuff like “Title” and “Author” fall between what is now the ‘latex leader’ and before what is now the ‘latex begin’ keys.


Actually, most of my metadata are in a file/doc in the "Front Matter" ahead of the Draft group, and they have worked pretty nicely there. That metadata gets loaded first, then the stuff in the compile settings?

In any case, my rationale is that i can save the compile settings to work in a more "universal" fashion if I put project specific meta data in a Front Matter file. Or does that not matter?

User avatar
AmberV
Posts: 20613
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Sun Dec 03, 2017 12:17 am Post

Yeah, so long as it works!That's a good way to go about it. You can also put project settings in the compile overview screen itself. There is a metadata tab over by contents, settings, etc. that also has a preview button you can click to see how all the metadata fits together. I like to use metadata files in the binder when a project has several different outputs. I can swap those out with the front matter setting, declare project universal stuff in the overview (author and such), and then document class and so on in the format itself.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

el
elw2u16
Posts: 8
Joined: Tue Nov 28, 2017 9:29 am
Platform: Mac

Wed Dec 06, 2017 1:08 pm Post

Hi,

It appears to be a MMD6 issue as I've reverted to MMD 5.4.0 and everything is working fine. Think I'll wait a while before updating :-)

thanks,
Emma

na
napaxton
Posts: 43
Joined: Wed Jan 19, 2011 5:42 pm
Platform: Mac

Wed Dec 06, 2017 4:52 pm Post

Hmm. While I'm glad it works, I don't think it is *strictly* an MMD 6 issue, as I have MMD6 on my home machine.

I know I am running MMD 6, because I have my MMD installed via Homebrew, so I've got a fairly recent version (no more than a week old right now).

User avatar
AmberV
Posts: 20613
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Wed Dec 06, 2017 5:04 pm Post

I do think it is a Scrivener problem, though I don’t know how to make it happen at will. The thing is I saw it happen with the plain MultiMarkdown output, which is entirely Scrivener’s job, that’s what gets passed along to MMD in the end, prior to there being any differences in versions.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles