Italic and Bold at MMD Import

Ze
ZeroDay
Posts: 10
Joined: Tue Aug 02, 2016 11:05 am
Platform: Mac + iOS

Tue Aug 02, 2016 1:12 pm Post

Hi,

i've a question about mmd import: when i'm importing files, everything works like it is described in the scrivener manual - except italic and bold markups. Both markups weren't "translated". I still see the markups like _ or *. Am i doing something wrong? I know that you can convert italic and bold rich text to mmd's but i can't find a way to do it the other way. And shouldn't it work straight with the import?

I've searched in the forum and via google about this problem, but couldn't find a solution yet. So, i hope someone can explain me what's wrong.

Thanks in advance,
zeroday

Ze
ZeroDay
Posts: 10
Joined: Tue Aug 02, 2016 11:05 am
Platform: Mac + iOS

Sat Aug 13, 2016 1:29 pm Post

Does nobody has the same problem?

User avatar
Silverdragon
Posts: 327
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac + iOS
Contact:

Sat Aug 13, 2016 3:34 pm Post

ZeroDay wrote:Does nobody has the same problem?

I've noticed it. It's irritating. Since this subforum is about MMD output, you may want to repost this in the Mac or Windows tech support forum. :)
So you know where I'm coming from:
• I'm a user, not an L&L employee.
• Mac Scrivener 2.9 & 3.0.0, MacBook Air 11, MacOS 10.12.6 (Sierra)
• iOS Scrivener 1.1.5, iPhone 6s, iPad Air 2, iOS 11.2

User avatar
AmberV
Posts: 20612
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Mon Aug 15, 2016 9:09 pm Post

ZeroDay wrote:i’ve a question about mmd import: when i’m importing files, everything works like it is described in the scrivener manual - except italic and bold markups.

Where are you seeing this in the user manual? All that is described (in §22.6, if you’re looking elsewhere let me know) is parsing the header levels from Markdown headings and generating an outline base on the document structure.

The sole purpose of the feature is to build an outline out of a document’s heading structure. If you want rich text out of an MMD file I would suggest using MMD to produce one, and then import that.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

Ze
ZeroDay
Posts: 10
Joined: Tue Aug 02, 2016 11:05 am
Platform: Mac + iOS

Tue Aug 16, 2016 3:55 pm Post

AmberV wrote:
ZeroDay wrote:i’ve a question about mmd import: when i’m importing files, everything works like it is described in the scrivener manual - except italic and bold markups.

Where are you seeing this in the user manual? All that is described (in §22.6, if you’re looking elsewhere let me know) is parsing the header levels from Markdown headings and generating an outline base on the document structure.

The sole purpose of the feature is to build an outline out of a document’s heading structure. If you want rich text out of an MMD file I would suggest using MMD to produce one, and then import that.


You understood me wrong. I meant that everything what is described in the manual works. Italic and bold isn't described there. But i expected it to work too. You're solution is obvious, but it's one step more than it should be necessary.

Ze
ZeroDay
Posts: 10
Joined: Tue Aug 02, 2016 11:05 am
Platform: Mac + iOS

Tue Aug 16, 2016 3:56 pm Post

Silverdragon wrote:
ZeroDay wrote:Does nobody has the same problem?

I've noticed it. It's irritating. Since this subforum is about MMD output, you may want to repost this in the Mac or Windows tech support forum. :)


Good advice. I will try that!

ol
ollave
Posts: 4
Joined: Mon Nov 14, 2016 11:15 pm
Platform: Mac

Mon Nov 14, 2016 11:28 pm Post

I've noticed (OS X, and even with MultiMarkdown and the OS X support files installed made no difference).
I will now go and look for the other thread and comment there. Importing italics and bold would be appropriate, I think.

ol
ollave
Posts: 4
Joined: Mon Nov 14, 2016 11:15 pm
Platform: Mac

Tue Nov 15, 2016 1:57 am Post

I've started a new thread as a "wish" since if what is documented works and this isn't documented, it isn't strictly a bug. :)

http://www.literatureandlatte.com/forum/viewtopic.php?f=4&t=36807