footnote problem

ba
baisui
Posts: 32
Joined: Sat Apr 24, 2010 9:18 pm

Mon May 16, 2016 5:42 pm Post

I'm working with MMD in Scrivener, then compiling to latex.

I have a very long document (book), which I've been working on for a while. Suddenly I seem to have a problem with footnotes. I have all three possible kinds of footnotes in the doc: (1) inline footnotes, (2) the other kind of Scriv footnote (that appears in the inspector), and (3) MMD footnotes:

[^footnote text]

Only the last of these three is being output to latex - the other two are not appearing at all.

Any ideas on how I can get them to appear?

I don't want to go through and convert them all manually, will take days!

Thanks!

User avatar
AmberV
Posts: 20613
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Mon May 16, 2016 9:20 pm Post

It is possible to switch footnote export off entirely, in the Footnotes & Comments compile option pane.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

ba
baisui
Posts: 32
Joined: Sat Apr 24, 2010 9:18 pm

Mon May 16, 2016 9:33 pm Post

I know, but I want to do the opposite, it's as if they've been turned off somewhere else, but I don't know where.

I didn't specify before, but on compiling to MMD I get the same result: only MMD footnotes:

[^blah blah]

are rendered as footnotes, other footnotes are ignored :-(

Thanks,

J

User avatar
AmberV
Posts: 20613
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Mon May 16, 2016 9:46 pm Post

Right, I meant that you should check that panel and make sure the checkbox isn’t ticked, because that is the only feature that will strip out footnotes. If that’s not the problem, could you describe what it takes to get to this point, starting from the “Original” compile preset (you might want to save your current settings to a project preset at the bottom of the Format As drop-down menu, first).
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles