Removing Form Feed characters from a .txt compile for Pandoc

St
SteveJT
Posts: 2
Joined: Thu Jul 14, 2011 7:29 pm
Platform: Mac

Thu May 05, 2016 7:19 pm Post

Hi all,

I have run into a little trouble with 'form feed' (insert page break) characters remaining in my document when I compile to .txt for use in Pandoc. In particular, my bookmarks are missed due to this. I am able to identify where they are when I read an .md file in a text editor, but can not seem to delete them.

I thought Plain Text compile removed all of this anyway.

Any help would be really appreciated.

Thanks,

Steve

User avatar
AmberV
Posts: 20613
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Thu May 05, 2016 9:19 pm Post

Text is not lost when using plain-text, only formatting. Whitespace controls like tab, space, carriage returns and form feeds are—despite controlling the appearance of the text, still text.

You should be able to paste one of these characters into the Edit/Find/Project Replace... feature and wipe them all out (definitely worth making a quick backup of the project prior to doing so).

If they aren’t actually in the project, maybe there is a stray character somewhere in your compile settings. Saving your settings to a preset and choosing something simple like “Original” should confirm whether or not they are coming from there. One thing comes to mind, you of course are using MMD, or at least Pandoc MD, but you might be using the regular Plain-Text (TXT) compile method instead of the “MultiMarkdown” method—if so the former will insert an FF if you have “Page Breaks” set anywhere in the Separators compile option pane. That will even happen with “Original”, which inserts page breaks between files and folders. Not many programs do much with the Form Feed, but TextEdit will show them as a page break.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

St
SteveJT
Posts: 2
Joined: Thu Jul 14, 2011 7:29 pm
Platform: Mac

Fri May 06, 2016 8:05 am Post

Thanks for the quick response AmberV,

Using Multimarkdown export works fine.

Thanks for your help!

Steve