Scrivener - BibDesk - TeXshop problem

wa
wagnertoph
Posts: 2
Joined: Tue Nov 10, 2015 3:35 pm
Platform: Mac

Tue Nov 10, 2015 3:48 pm Post

Hello,
apologies if this has been covered somewhere, but after looking through various guides, blogs and help pages I'm still a bit stuck.
I am writing in Scrivener, with BibDesk as bibliography manager. I have installed MMD 4.7.1 and the LaTex support files in the freshly created ~/Library/texmf/tex/latex/mmd folder.
I then create a LaTex file using the compile menu in Scrivener, with "Bibliostyle" set to "harvard". I set the LaTex document class to "Article".
When I then run the resulting .tex file through TeXshop, (first Typeset LaTex, then Typeset BibTex, then Typeset LaTex, then Typeset LaTex again), I get a nice looking pdf, but it cannot find the harvard bibliography style. I know the harvard.sty file exists, alongside all the other .sty files. I have not manually moved any tex related files, other than creating the folder for the MMD LaTex suport files as described above.
This is the error I get:
I couldn't open style file harvard.bst
---line 22 of file test.aux
: \bibstyle{harvard
: }
I'm skipping whatever remains of this command
I found no style file---while reading file test.aux
(There were 2 error messages)


Any ideas why this isn't working? You can probably tell I'm very new to this, since I don't even know which piece of software the problem lies with, but I would really appreciate some help in getting this to work.
Best wishes,
Christoph

User avatar
AmberV
Posts: 20600
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Tue Nov 10, 2015 9:37 pm Post

Yeah, this is a LaTeX question, several miles away from where Scrivener operates. :) I pasted your error message into a web search and found this result fairly high up:

http://tex.stackexchange.com/questions/39454/how-do-i-use-the-harvard-citation-style

Seems the ‘harvard’ style is not something most people use anyway, preferring instead to use natbib with the proper mode settings.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

wa
wagnertoph
Posts: 2
Joined: Tue Nov 10, 2015 3:35 pm
Platform: Mac

Mon Jan 18, 2016 11:18 am Post

Hello,
in case anybody else experiences the same issue, here is the solution I eventually found. The Harvard bibstyle has various different versions included in it, in order to use it in Scrivener you need to define which one you want to use. So the correct entry for Bibliostyle is not "harvard", it's whichever particular version of harvard you need, in my case "agsm" worked well.

Best wishes,
Christoph