Shortcut or Button for Edit / Transformations / Make Title Case

ol
olonoff
Posts: 44
Joined: Mon Sep 19, 2011 1:58 pm
Platform: Mac
Location: Millsboro, DE and Springfield, VA
Contact:

Thu Mar 01, 2018 12:26 pm Post

I have a great number of words that need to be converted to Title Case. (I'm using Dragon dictate, and one of my characters is named "Petty" which is a word, so Dragon types it as "petty.") Is there any way to speed up the process? I'd like to find a keystroke combination for Edit/Transformations/ Make Title Case. Is that possible? Thanks.

Online
User avatar
AmberV
Posts: 22010
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Thu Mar 01, 2018 12:45 pm Post

Custom keyboard shortcuts are discussed in appendix A.1 of the user manual. If you use case adjustments frequently, you can add a shortcut to the commands to make using them more efficient.

Do note that you will need the cursor in the word, or to have the word selected. So if the result of dictation is “petty |” with the cursor blinking after a space, or even at the very end of the word, the shortcut won’t work all by itself. If you use a macro program, or even something like BetterTouchTool, you could compound three commands into one:

  1. ⇧⌥←: Select the word to the left of the cursor.
  2. Capitalise it (you’d just need to trigger the menu command here rather than having a shortcut).
  3. : Move the cursor to the rightward end of the selection (and thus returning it precisely to wherever it was before starting the macro).

Now something else that might work—it would with normal typing, I don’t know if will with dictation—is to add the noun to the project’s auto-complete list. You can right-click on it to do so—and capitalisation is significant in the auto-completion system. Thus if you type in ‘pe’ the system will suggest ‘Petty’ and you can hit the Tab key to complete it. (This works better with Suggest completions as you type enabled in the Corrections preference pane). Again, that might not work well with dictation, as it might insert the whole word at once, bypassing completion since there is nothing left to complete.

Does Dragon not have a way of informing it of proper nouns, or a way of modify a word so that it is capitalised from the start? Seems that would be a problem in general worth resolving on their end—or does everyone using Dragon to write about the village of Cheddar have to battle against capitalisation over and over?
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

ol
olonoff
Posts: 44
Joined: Mon Sep 19, 2011 1:58 pm
Platform: Mac
Location: Millsboro, DE and Springfield, VA
Contact:

Wed Mar 07, 2018 2:34 pm Post

I have been able to create shortcut for Make Title Case, (Cmd Shift T) using the instructions in the Manual Appendix. However I've been unsuccessful thus far in creating a short cut for Make Lowercase. I've tried several keystroke combinations, but no success. I'm wondering if Scrivener for some reason does not allow this? I've tried reassigning existing keystroke combinations but to no avail. What am I doing wrong?

Online
User avatar
AmberV
Posts: 22010
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Wed Mar 07, 2018 3:44 pm Post

Hmm, no I can’t think of anything that would stop you from doing that, unless the shortcuts you were trying to use are globally bound elsewhere. I just tried adding ⌃U to “Make Lowercase” and it worked fine. Well sometimes it helps to provide the full path in the shortcut name field: “Edit->Transformations->Make Lowercase”.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

ol
olonoff
Posts: 44
Joined: Mon Sep 19, 2011 1:58 pm
Platform: Mac
Location: Millsboro, DE and Springfield, VA
Contact:

Wed Mar 07, 2018 3:58 pm Post

Thanks very much -- that worked. Interestingly, I had to use the entire path for Make Lowercase, but not for Title case. When I didn't do that I got a beep.

Online
User avatar
AmberV
Posts: 22010
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Wed Mar 07, 2018 4:27 pm Post

That is strange—I didn’t have to supply the whole path. Is it possible that you have a file called “Make Lowercase” in your binder? :) Probably not, but that’s one area where menu commands can steal shortcuts deep into places you wouldn’t expect, like the Edit ▸ Link to Document ▸ Draft ▸ Show Invisibles. And now the View ▸ Text Editing ▸ Show Invisibles command doesn’t get the shortcut.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

ol
olonoff
Posts: 44
Joined: Mon Sep 19, 2011 1:58 pm
Platform: Mac
Location: Millsboro, DE and Springfield, VA
Contact:

Wed Mar 07, 2018 4:35 pm Post

You are right. In Preferences, I shortened the path to just Make Lowercase and it worked the second time. Not sure what happened the first time. Probably operator error! Anyway, thanks for the help!!!