[SOLVED] Scrivener 3 appears to not convert Scriv2 files when I try to open them

Posts: 1
Joined: Sat Feb 03, 2018 8:39 pm
Platform: Mac

Sat Feb 03, 2018 8:44 pm Post

I have tried to open Scriv2 files (I'm on a 2017 iMac 10.13.3) and Scrivener appears to not understand what I'm doing. This happens from both Finder and Scrivener app via Open dialog.

In either case, I navigate to the .scriv file I want and double-click. I get the animation that says the file is being launched, but then nothing. The Initial scrivener dialog window (where I could create a new project) is there. Nothing shows in the Window menu. I can clearly see that the files exist, and in Finder they show as updated today, but they don't actually launch.

I can still open these files in Scrivener on my iPad.

I would understand if it was just taking a bit of time to convert, but I tried opening tiny files (one text document, under 2000 words) and I'm also getting nothing.

I do use Dropbox, but as I said, the same files work just fine in iOS scrivener.

EDIT: Okay apparently the problem was that I couldn't see the prompt to allow Scrivener to access my contacts and so nothing was happening. a restart made that prompt visible and then it worked. Sorry for the waste of anyone's time.