Page number footer too low.

Da
Dawn Doyle
Posts: 19
Joined: Sat Mar 18, 2017 8:49 am
Platform: Mac

Thu Dec 28, 2017 3:33 pm Post

Hi.
I've been formatting my novel, and I can't seem to get the page number footer to move up.
I know I can change the margins, but I have to have the lower margin set at 2" before the page number can be within the printing lines.
I usually have my bottom margin set at 0.5", and I never had a problem with Scrivener 2, which used to have the page number at a set height, regardless of the margin size.
Does anybody know how to adjust it, because my file keeps getting rejected because the page numbers fall below the print line.

Many thanks.

User avatar
Bridey
Posts: 390
Joined: Wed Nov 22, 2017 2:24 pm
Platform: Mac

Thu Dec 28, 2017 6:52 pm Post

From page setup, I *believe* this will help...

viewtopic.php?p=197355#p197355

Page Setup.jpg
Page Setup.jpg (277.24 KiB) Viewed 2372 times

User avatar
xiamenese
Posts: 3684
Joined: Mon Jan 29, 2007 1:32 am
Platform: Mac
Location: London or Exeter, UK.

Thu Dec 28, 2017 7:09 pm Post

I was wondering if the OP's problem was that at the moment the default paper size is A4, whereas the paper size set through the printer is US Letter, and she wants to compile to the latter. That can cause problems like this

Mark
The Scrivenato sometimes known as Mr X.
rMBP 13" (early 2015) 10.13.6, 8GB RAM, 512GB SSID
MBP17" (late 2011) 10.13.6, 8GB RAM, 512GB SSID
2017 iPad, iOS 12.01, 128GB, Apple Pencil
Scrivener, Scapple, Nisus Writer Pro, Bookends …

Da
Dawn Doyle
Posts: 19
Joined: Sat Mar 18, 2017 8:49 am
Platform: Mac

Tue Jan 02, 2018 2:53 pm Post

Many thanks for your replies. I'm in the UK, so A4 would be my printer size, not US letter. However, I'm compiling to 5x8 and using Novel settings that I imported from Scrivener 2.
Sorry, I should have made myself clearer.
After some changes to the setup, which I always used in Scrivener 2, the page numbers are too low.
I'm not compiling to print it out, I'm compiling to upload my PDF to Createspace. I've never had this issue, until now.

User avatar
Bridey
Posts: 390
Joined: Wed Nov 22, 2017 2:24 pm
Platform: Mac

Tue Jan 02, 2018 3:18 pm Post

And you weren't able to adjust the page settings?

viewtopic.php?p=256261#p256261

Da
Dawn Doyle
Posts: 19
Joined: Sat Mar 18, 2017 8:49 am
Platform: Mac

Tue Jan 02, 2018 4:43 pm Post

Bridey wrote:And you weren't able to adjust the page settings?

viewtopic.php?p=256261#p256261


I can adjust my page size and the margins, but the page numbers don't change. I couldn't find anywhere that woul dgive me that option.
I think Scrivener 2's settings were so much easier and user friendly. I didn't even have a Novel setting until I imported it from Scrivener 2.

Please see the attachment. The page number is too close to the bottom.
Attachments
Screen Shot 2018-01-02 at 18.27.56.png
Screen Shot 2018-01-02 at 18.27.56.png (82.82 KiB) Viewed 2214 times

Da
Dawn Doyle
Posts: 19
Joined: Sat Mar 18, 2017 8:49 am
Platform: Mac

Sun Jan 14, 2018 10:58 pm Post

Sorry to bump this, but I've still had no luck in figuring out how to adjust the page number footer.
Does anybody know how?

User avatar
KB
Site Admin
Posts: 20507
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Mon Jan 15, 2018 5:21 pm Post

I'm not sure what you mean about Scrivener 2's settings being more friendly - nothing in the settings affects this, and I worked very hard to ensure that Scrivener 3's Compile settings were simpler, more user-friendly and more powerful. I have updated the algorithm used to place page numbers, though, as these could sometimes end up writing over the text in Scrivener 2.

As to the issue at hand, the placement of the page number in the margin can be affected by your printer's non-printable area (even if you are not printing but are creating a PDF - an anomaly of macOS). So what you could try is this:

1. In your Compile format, go "Page Settings". If "User project page settings" is not ticked, then click on "Page Setup". If it is ticked, then close Compile and go to File > Page Setup instead. (This assumes you are using your own Compile format. If not, Ctrl-click on the format in the list and use "Duplicate & Edit" before following these instructions.)

2. In Page Setup, select "Manage Custom Sizes..." next to "Paper Size".

3. Click "+" to create a new paper size based on whatever you have selected (e.g. A4) and give it a name in the side bar (e.g. "A4 (Fixed)").

4. Change the "Top" and "Bottom" values of the Non-Printable area.

Save the page size and try Compiling. (Note that all of these settings would have needed to be tweaked in Scrivener 2, too, if you had problems with header/footer placement.)

Generally, if the bottom margin is 0.5", the page number will appear around 0.25" from the bottom. In your screenshot, this actually looks fine. If that's a half-inch margin, then the page number looks as though it's in the right position. Depending on your page size and formatting settings, it may be that the last line that could fit on the page is getting pushed to the next page. In that case you could just use a larger bottom margin to push up the page number anyway.
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

Da
Dawn Doyle
Posts: 19
Joined: Sat Mar 18, 2017 8:49 am
Platform: Mac

Mon Jan 15, 2018 8:28 pm Post

Hi, and thank for your reply.
I've already tried doing this, and posting was a last resort.
In Scrivener 2, I used a 0.5" margin, and the numbers were placed higher. I know that they've changed, because when I now upload my PDF to Createspace, the numbers are outside the printable area.
Here are two examples:
The one with page number 6 is from Scrivener 3, while the page 7 is from Scrivener 2. Both have 0.5 set as the bottom margin.
The Scrivener 2 has been formatted with the Paperback Novel preset with the settings adjusted. I couldn't replicate the same settings with Scrivener 3.
Screen Shot 2018-01-15 at 19.45.59.png
Screen Shot 2018-01-15 at 19.45.59.png (111.44 KiB) Viewed 2041 times

Screen Shot 2018-01-15 at 20.24.30.png
Screen Shot 2018-01-15 at 20.24.30.png (85.1 KiB) Viewed 2041 times

Da
Dawn Doyle
Posts: 19
Joined: Sat Mar 18, 2017 8:49 am
Platform: Mac

Mon Jan 15, 2018 9:25 pm Post

Ok, so I just put the page numbers at the top corner instead.

User avatar
lunk
Posts: 2841
Joined: Wed Aug 21, 2013 4:24 pm
Platform: Mac + iOS
Location: Sweden 64° N

Mon Jan 15, 2018 9:29 pm Post

The lower image looks like you have 1” margin, not 0.5
I am a user, writing non-fiction and science, using:
* Mac Scrivener 3 on a Macbook 12”, MacBook Pro 13”, and iMac 27”, all running the latest MacOS
* iOS Scrivener 1 on an iPhone 8, iPad Air 9.7”, and iPad Pro 12.9”, all running the latest iOS

Da
Dawn Doyle
Posts: 19
Joined: Sat Mar 18, 2017 8:49 am
Platform: Mac

Mon Jan 15, 2018 9:38 pm Post

lunk wrote:The lower image looks like you have 1” margin, not 0.5

I know, but I assure you, it's not. That was with the Paperback preset in Scrivener 2, and me changing the margins to 0.5.
However, I can't seem to get Scrivener 3 to do the same, even with the Papaerback preset.

User avatar
lunk
Posts: 2841
Joined: Wed Aug 21, 2013 4:24 pm
Platform: Mac + iOS
Location: Sweden 64° N

Mon Jan 15, 2018 9:46 pm Post

Okay, I’ll rephrase it:
The lower image looks exactly like my manuscript pdf compiled for and accepted by Createspace using a 1” bottom margin.
The distance from the paper edge to the text is not 0.5” in your lower image so what you are saying is essentially that v3 does it correctly while you managed to get v2 to get a 1” margin in spite of you setting it to 0.5”.
I am a user, writing non-fiction and science, using:
* Mac Scrivener 3 on a Macbook 12”, MacBook Pro 13”, and iMac 27”, all running the latest MacOS
* iOS Scrivener 1 on an iPhone 8, iPad Air 9.7”, and iPad Pro 12.9”, all running the latest iOS

Da
Dawn Doyle
Posts: 19
Joined: Sat Mar 18, 2017 8:49 am
Platform: Mac

Tue Jan 16, 2018 12:20 am Post

lunk wrote:Okay, I’ll rephrase it:
The lower image looks exactly like my manuscript pdf compiled for and accepted by Createspace using a 1” bottom margin.
The distance from the paper edge to the text is not 0.5” in your lower image so what you are saying is essentially that v3 does it correctly while you managed to get v2 to get a 1” margin in spite of you setting it to 0.5”.

It might have something to do with the old Paperback Novel compile preset in S2, then. I can replicate S3's results with S2. It took a while, but I just used the default and then changed all of the settings to a paperback, and the margins.
However, using S3's paperback preset doesn't have the same affect.
Either way, regardless if it's now correct, the page numbers are out of the printable area. No matter how I change it at the bottom, even with the instructions shown above to change the page settings through the File tab, it stays in the same place.
To fix that problem, I've just put the numbers on the top instead.

Et
EtienneP.
Posts: 4
Joined: Mon Mar 05, 2018 4:03 pm
Platform: Mac

Mon Mar 05, 2018 4:19 pm Post

Easy fix. If you want to change the position of the page number (or any kind of footer text), in a pdf compile :
you can do so in Compile / formatting / footer :

Simply add one blank line after the page number, by typing ALT ENTER after <$p>.
This will shift the page number one line up.

You can add one or more blank lines, since Alt Enter = carriage return.

You can get the opposite result by adding one blank line on top of the page number (by typing ALT ENTER before <$p>) : this will shift the page number one line down.

PS : talking about Scrivener 2 here.