Compile Creates One Long Run-On Paragraph

ja
jackm1
Posts: 1
Joined: Wed Dec 06, 2017 1:03 pm
Platform: Mac

Wed Dec 06, 2017 1:11 pm Post

I think I've messed up the compile settings somehow. No matter what I do, all text appears as a single run-on paragraph. this applies to any text. I have tried different settings with no results. This never happened with v2.

Any help is much appreciated.

News. If I select the convert MultiMarkdown to rich text in text and notes, all the paragraph marks vanish. Is there a way to fix this?

Scrivener 2 had a compile option to convert markdown to italics and bold. I don't see that option anymore. Have I missed something?

Br
BrianJJarrett
Posts: 3
Joined: Thu Dec 07, 2017 1:30 am
Platform: Mac

Thu Dec 07, 2017 1:58 am Post

I'm having the same problem. Paragraphs are now run-on sentences after compilation (both mobi & epub 2 & 3). All paragraph breaks are gone.

Also unformatted/as-is documents (like front/back matter) are not obeying the formatting used in the editor. Instead of compling centered, the text is left-justified and loses return characters.

This happens on imported/converted V2 files as well as brand new files built directly from the default "Novel" template.

My imported Scrivener files are nothing fancy; an old V2 template...just simple folder chapters and text scenes. My converted files do appear to have mapped to the new format properly, but they still won't compile correctly.

I've gone through the tutorial and followed all the instructions and yet I still cannot get an ebook to compile properly with any of my attempts. That said, at least multimarkdown italics work. :)

I like the new compile approach, but unfortunately if I can't compile an ebook then there's little choice left for me than to revert back to V2 and call it a day. I'm currently running V2 side-by-side with V3, so it's not keeping me from writing. It's just disappointing because I was really excited about V3. :cry:

Br
BrianJJarrett
Posts: 3
Joined: Thu Dec 07, 2017 1:30 am
Platform: Mac

Thu Dec 07, 2017 2:04 am Post

UPDATE: If I turn off "Convert Multimarkdown to rich text in notes and text" during compile, my formatting issues go away! I lose my markdown italics, of course, but it's a step in the right direction.

Hope this update helps. Fingers crossed that this gets fixed and then I can move over to V3 after all!

User avatar
kewms
Posts: 3219
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Thu Dec 07, 2017 3:45 am Post

The disappearing paragraph marks are a side effect of the Markdown conversion, which is more aggressive in Scrivener 3. The solution is to use a Replacement to replace single paragraph marks with doubles: the Markdown conversion will only remove one of them.

Katherine
Scrivener Support Team

Br
BrianJJarrett
Posts: 3
Joined: Thu Dec 07, 2017 1:30 am
Platform: Mac

Fri Dec 08, 2017 11:38 am Post

Hi Katherine,

Thanks so much for the quick reply. I tested your proposed solution and it does work.

It's unfortunate that Multimarkdown behavior changed from V2 to V3 because it had recently become useful to me. That said, I only used Multimarkdown to preserve italics when copying to/from grammar checking software that wouldn't retain my native rtf formatting, so I'm not sure it's worth adding extra new lines throughout to the manuscript to continue marking down italics. I can just manually replicate the behavior for what little italics formatting I use as a work around.

In the end, the new features of V3 outweigh a wee bit of formatting problems, so I'm officially switched over to Scrivener 3. :D

Thanks again for your help.

Brian