numbered lists: import/export Scrivener <> MS Word

wo
wodecki
Posts: 2
Joined: Wed Nov 22, 2017 10:37 am
Platform: Mac

Mon Dec 04, 2017 7:51 am Post

Hi,

I want to import my book from MS Word, complete it in Scrivener, and export back to MS Word with all styles kept intact.
I have a problem with numbered list.
1. In my original MS Word I have a simple list, styled eg with "Paragraph List":
1. word imported.png
This is my numbered list in MS Word
1. word imported.png (27.69 KiB) Viewed 1138 times


2. This is how it appears in Scrivener.
2. after import to S.png
2. after import to S.png (76.55 KiB) Viewed 1138 times

Note it is styled as "No style"

3. Then I compile the file to MS Word (template: General Non-Fiction, format: Non-Fiction Manuscript (Times)), open exported MS Word and obtain sth like that:
3. after export to MS Word.png
3. after export to MS Word.png (37.61 KiB) Viewed 1138 times


Result:
1. Numbers and letters are repeated
2. Style of the text in MS Word is "Normal"

My question: how to set up the Scrivener in such a way, that it will:
1. import Numbered Lists and Lists?
2. export them without "double-numbering" and with MS Word Paragraph list applied?

I would appreciate Your help. With hundreds of pages it's close to impossible to manually correct all the list...

Many thanks for tips in advance,

Andy

Ma
MarcusK
Posts: 4
Joined: Fri Feb 23, 2018 11:38 pm
Platform: Mac

Sat Feb 24, 2018 5:00 am Post

Can I bump this issue back up. I am using V3 for Mac (great update by the way) and I am having the same problem.

I dragged and dropped the word doc in. Clicked the numbering button to remove and reinsert the numbers (in a simple list) then compiled to word and either the first line has a double number or all of them do.

Interestingly I find if I compile to PDF it is not an issue and if I click and delete the number manually but leave the format as numbered list, after compiling Word displays the list properly numbers and all. It works ATM because I only have a few lists in the doc. But it means I need to keep track of where I have done this workaround otherwise I have to manually fix it after compiling to word.

I have tested importing and splitting, clearing formatting, pasting and matching style etc as described in the blog post and still no luck.

User avatar
kewms
Posts: 4007
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Sat Feb 24, 2018 6:27 am Post

The most likely cause of this is that Word's autoformat features are configured to detect and format lists. The solution is to disable those features.

You can test by compiling to RTF and opening the result in TextEdit. The outline should be formatted correctly, demonstrating that Scrivener's output is correct. If you then open the RTF file in Word, the anomalous formatting will likely reappear.

Katherine
Scrivener Support Team

Ma
MarcusK
Posts: 4
Joined: Fri Feb 23, 2018 11:38 pm
Platform: Mac

Sun Feb 25, 2018 1:24 am Post

Thank you. I went ahead and did as you suggested, following the instruction in here [url]washburnlaw.edu/library/technology/tutorials/autoformat-mac.html[/url]
however, it didn't resolve the issue. I actually unticked 'auto correct both spelling and formatting completely' and then compiled, but it ended up looking the same with double numbering.
i also tested your suggestion to compile to RTF and it appeared correctly, but that is not going to help as most of the destinations of the documents i create require word documents.
any other suggestions?

User avatar
kewms
Posts: 4007
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Sun Feb 25, 2018 6:58 am Post

Did you untick bulleted lists and numbered lists under "Apply as you type."

Does the formatting reappear if you open the (verified correct) RTF file in Word?

Katherine
Scrivener Support Team

Ma
MarcusK
Posts: 4
Joined: Fri Feb 23, 2018 11:38 pm
Platform: Mac

Sun Feb 25, 2018 8:22 am Post

yes, i have tried all options. untick one or the other or both, untick and then force quit word, untick and restart the machine. Compile to rtf, verify that it appears properly in TextEdit, then open in word and the double dot points or numbers appear again.

any other suggestions?

User avatar
kewms
Posts: 4007
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Sun Feb 25, 2018 8:10 pm Post

MarcusK wrote:yes, i have tried all options. untick one or the other or both, untick and then force quit word, untick and restart the machine. Compile to rtf, verify that it appears properly in TextEdit, then open in word and the double dot points or numbers appear again.

any other suggestions?


If the file appears correctly in TextEdit, but the bullet points are wrong in Word, then it is a Word issue and you might have more success contacting Microsoft support.

Katherine
Scrivener Support Team

User avatar
xiamenese
Posts: 3636
Joined: Mon Jan 29, 2007 1:32 am
Platform: Mac
Location: London or Exeter, UK.

Sun Feb 25, 2018 9:33 pm Post

You said you

untick one or the other or both, untick and then force quit word,

Why did you force quit? My instinct says that if you force quit it won't save any of the reset options/preferences.

Just a thought.

Mark
The Scrivenato sometimes known as Mr X.
rMBP 13" (early 2015) 10.13.6, 8GB RAM, 512GB SSID
MBP17" (late 2011) 10.13.6, 8GB RAM, 512GB SSID
2017 iPad, iOS 12.01, 128GB, Apple Pencil
Scrivener, Scapple, Nisus Writer Pro, Bookends …

Ma
MarcusK
Posts: 4
Joined: Fri Feb 23, 2018 11:38 pm
Platform: Mac

Sun Feb 25, 2018 9:53 pm Post

sorry, i should have said i have worked through the issue using the process of elimination. I didn't list the steps i followed out, in the post otherwise the post would have been very long.

The force quit was one of the alternatives i tried, Interestingly, even though i forced quit, the settings maintained the state i.e the tick boxes remained not ticked, Obviously, if you close the settings window in word on Mac, before force quitting, it retains the settings.

i will pop over to the office forums and report this issue, But I do wonder if Scrivener is rendering paragraphs with the numbered list or bullet list style properly. the way i see it, scrivener is not formatting the list style with numbering, but inserting a number/bullet and a dot point (if appropriate) as text when you click the list button on the formatting tab.
It is also formatting the paragraph with the list style. Which is why the paragraph maintains a numbered format when i delete the number inserted by scrivener and compile to word - the paragraph is still formatted as a list style.

Maybe it could be managed at a code level a different way. For example, when i click the list button on the menu, it inserts a text based numbering but does not format the paragraph as a list style (not my preferred). Alternatively, it formats the paragraph as a numbered list and then renders the style with numbering (similar to what MS word does), in which case it will render it properly in both software. Just a thought.

User avatar
kewms
Posts: 4007
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Sun Feb 25, 2018 11:52 pm Post

MarcusK wrote:Maybe it could be managed at a code level a different way. For example, when i click the list button on the menu, it inserts a text based numbering but does not format the paragraph as a list style (not my preferred). Alternatively, it formats the paragraph as a numbered list and then renders the style with numbering (similar to what MS word does), in which case it will render it properly in both software. Just a thought.


Use of Styles is optional in Scrivener. Forcing a user to apply a Style in order to make a list would have ripple effects down the line, including making the Compile command more difficult to use.

Katherine
Scrivener Support Team