Font size keeps getting overridden (Scrivener 3)

zf
zfkeller
Posts: 8
Joined: Fri Jun 01, 2012 1:56 am
Platform: Mac

Sun Dec 03, 2017 5:30 pm Post

Hey everyone. In my front matter, I have a title page with the title style set to TITLE and my name set to HEADING 1. I have the section layout set to "As Is" in order to preserve my font size (larger) and style (bold), however, when viewed in Kindle Previewer it shows that the font is the same size as the body text, and the bold styling has been removed.

1. Where is the font override check box in Scrivener 3?
2. How do I maintain the style of what I have in the editor (As Is doesn't appear to be working).

Thanks for your help.

so
somatic
Posts: 9
Joined: Tue May 22, 2018 4:45 pm
Platform: Mac

Mon Jun 04, 2018 12:23 am Post

zfkeller wrote:Hey everyone. In my front matter, I have a title page with the title style set to TITLE and my name set to HEADING 1. I have the section layout set to "As Is" in order to preserve my font size (larger) and style (bold), however, when viewed in Kindle Previewer it shows that the font is the same size as the body text, and the bold styling has been removed.

1. Where is the font override check box in Scrivener 3?
2. How do I maintain the style of what I have in the editor (As Is doesn't appear to be working).

Thanks for your help.


I have a similar issue. The Title Page with book name 36pt and my name 24 pt show up the same as body text on the kindle. What is the proper way to get around this? Section Layout was set to New Section and then I tried As Is with no luck. I also restyled the text to "Title" and "Heading 1" like stated above and nothing. I'm lost here.

User avatar
KB
Site Admin
Posts: 19857
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Mon Jun 04, 2018 4:10 pm Post

It's a little difficult to know what is going on without seeing the project. Would it be possible to zip up and attach a sample project showing the issue?
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

so
somatic
Posts: 9
Joined: Tue May 22, 2018 4:45 pm
Platform: Mac

Tue Jun 05, 2018 5:40 pm Post

I can work on doing that. Post it here or can I email it somewhere and reference this thread?

User avatar
KB
Site Admin
Posts: 19857
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Tue Jun 05, 2018 5:57 pm Post

If it's a sample project you can share, then just zip it up and attach it using the "Attachments" tab beneath the reply box here. If you would rather not share it publicly, please email it to us at mac.support AT literatureandlatte.com.

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

so
somatic
Posts: 9
Joined: Tue May 22, 2018 4:45 pm
Platform: Mac

Thu Jun 07, 2018 1:53 am Post

Here you go. Would love to know what I am doing wrong. The Title page will not display large font. It seems to be an issue with the Front Matter for me.
Attachments
Archive.zip
(615.53 KiB) Downloaded 16 times

User avatar
KB
Site Admin
Posts: 19857
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Thu Jun 07, 2018 6:52 pm Post

Hi,

In the attached project, no styles are associated with the text in the title page. for Kindle KF8 and Epub 3, you need to use styles to set off areas of text that should use different sizes. For instance, try assigning the "Title" style - or you can make your own style to suit you better. (Note that the "Title" style isn't centred in the editor, but Compile overrides it to centre it so will look fine in the ebook.)

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

so
somatic
Posts: 9
Joined: Tue May 22, 2018 4:45 pm
Platform: Mac

Fri Jun 08, 2018 12:18 am Post

Keith, thanks for looking at it. I must be holding my tongue wrong but everything is working fine. I will chalk this up to me. I went ahead and created a few new Style text options. Works great on the title page now. Again, thank you.

so
somatic
Posts: 9
Joined: Tue May 22, 2018 4:45 pm
Platform: Mac

Sat Jun 09, 2018 1:57 pm Post

A bit off topic but since the project file is uploaded to this thread, can you tell me how to increase the distance between the Title of the book and the authors name? When I hit return to spread them apart it seems it only spreads them apart a max distance that is still close to each other (to me). I have also tried inserting line breaks from the menu.

Is there some setting in compile that limits this in the Front Matter I missing or am I just fumbling this up again?

User avatar
KB
Site Admin
Posts: 19857
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Mon Jun 11, 2018 12:53 pm Post

That's strange, as using return works fine for me. I would recommend using a style, though (such as creating a "Book Title" style that you apply to the book title) and then using paragraph spacing. So, for instance:

1. Set up the book title as you want it in the editor.

2. Use line spacing (Format > Paragraph > Line and Paragraph Spacing..., or from the control in the format bar) to set the "Paragraph spacing after" to something big.

3. Select the title and use Format > Styles > New Style From Selection to turn this into a style. Styles are preserved during Compile to ebook formats, so this will ensure the paragraph spacing is maintained.

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

jo
johnro
Posts: 117
Joined: Mon Sep 26, 2011 2:57 am
Platform: Mac
Location: Minneapolis, MN
Contact:

Sat Jun 16, 2018 11:11 pm Post

I have a similar problem. My title page correctly compiles (to PDF, in this case) the title using the font 'chunk 5'. But my name keeps coming up Helvetica, no matter what font I use in the Scrivener front matter. Having read posts here, I tried to make a style called Author (attached 'author style') using Book Antiqua 24 point. "Author" shows up as Book Antiqua in the attached 'Scrivener Title Page', but the compiled result ('compile') still has Helvetica.
Attachments
Screen Shot 2018-06-16 at 6.04.15 PM.png
Scrivener title page
Screen Shot 2018-06-16 at 6.04.15 PM.png (32.01 KiB) Viewed 183 times
Screen Shot 2018-06-16 at 6.04.51 PM.png
compile
Screen Shot 2018-06-16 at 6.04.51 PM.png (34.27 KiB) Viewed 183 times
Screen Shot 2018-06-16 at 6.08.05 PM.png
author style
Screen Shot 2018-06-16 at 6.08.05 PM.png (47.51 KiB) Viewed 183 times

jo
johnro
Posts: 117
Joined: Mon Sep 26, 2011 2:57 am
Platform: Mac
Location: Minneapolis, MN
Contact:

Sun Jun 17, 2018 11:27 pm Post

In answer to my own post, and a cautionary tale: I kept being unable to select a preferred font for my name on the title page of my novel. I finally figured it out: Scrivener was using the e-book settings for the title page when I checked compile front matter. Possibly my selection. Anyway, I deep-mixed the e-book format front matter, and the situation resolved.

so
somatic
Posts: 9
Joined: Tue May 22, 2018 4:45 pm
Platform: Mac

Sun Jun 17, 2018 11:32 pm Post

Can you post a screenshot where you figured this out?