Page 2 of 2

Re: European stressed vowels problem

Posted: Mon Jul 03, 2017 8:56 am
by pedrober
Thank you very much for your advice. I'm waiting for a solution from the Scrivener's Technical Support. It's a serious problem for any European user.

Re: European stressed vowels problem

Posted: Mon Jul 03, 2017 10:09 am
by xiamenese
pedrober wrote:Thank you very much for your advice. I'm waiting for a solution from the Scrivener's Technical Support. It's a serious problem for any European user.

That needs to be emended: it's a serious problem for you, and maybe for others using the Spanish keyboard setting, but not for all European users. There are many European users, Spanish, Italian, French, German, Swedish …, who have been using Scrivener for years and never had this problem. The only report I have seen of it, is in Matsgz's post above.

That is not to devalue the problem you have, but it is wrong to extrapolate from your experience to all European users

Mark

Re: European stressed vowels problem

Posted: Tue Jul 04, 2017 9:40 am
by ScriverTid
pedrober wrote:Thank you very much for your advice. I'm waiting for a solution from the Scrivener's Technical Support. It's a serious problem for any European user.

In the meantime, have a look at the Keyboard Viewer (accessible either via System Preferences or it's already showing in your menubar). In particular hold down the Option key which shows you all the diacritics which are accessed via that key. The ones in orange are accents that can be used over more than one letter, so you have to press Opt+char, then the letter you want the accent over.

Re: European stressed vowels problem

Posted: Tue Jul 04, 2017 9:32 pm
by pedrober
Thank you for your message.
The Keyboard Viewer shows the two dead keys present in Spanish ISO keyboard: ´ and ` (in orange, as you stated).
If I press the Option key, I see another dead key (~, in orange too), the one that lets me create Portuguese stressed vowels.

Re: European stressed vowels problem

Posted: Wed Jul 05, 2017 10:19 am
by pedrober
Just a correction: I have found something similar devices to the yellow box attached by ScriverTid in other programs (and even the same yellow box) but it works without any problem or limitation to my typing speed.

Re: European stressed vowels problem

Posted: Wed Jul 05, 2017 5:04 pm
by pedrober
Shockng find: the problem is linked to my home made "dark theme" (see: http://www.literatureandlatte.com/forum ... =4&t=38312). If I restore defaults or use a less radical approach to screen customization, no problem when I type European stressed vowels. Any comment?

Re: European stressed vowels problem

Posted: Fri Jul 21, 2017 11:50 am
by pedrober
I have discovered the origin of the problem. It was related to my preferences but not to my home made "dark theme". The problem with dead keys only appears when Auto-Completion is activated.
Suggest completion as you type: checked.
In script mode only: unchecked.
Only suggest completions from auto-complete list: checked.
A possible bug?

Re: European stressed vowels problem

Posted: Thu Mar 08, 2018 12:46 pm
by Daniel P. Espinosa
pedrober wrote:I have discovered the origin of the problem. It was related to my preferences but not to my home made "dark theme". The problem with dead keys only appears when Auto-Completion is activated.
Suggest completion as you type: checked.
In script mode only: unchecked.
Only suggest completions from auto-complete list: checked.
A possible bug?


Well, this worked! After months suffering from this problem (and posting in the forum beacuse I haven't seen yours), your solution worked for me.

Indeed it is a bug for Spanish typing on Scrivener, and it should be corrected.

In the meantime, I can live without the autocompletion feature :) Thanks for your efforts!