Not opening recent documents on log-in

da
dagaz
Posts: 130
Joined: Fri Jul 14, 2006 8:46 am
Location: Murwillumbah, Australia

Wed Nov 15, 2006 5:28 am Post

Didn't think this was worthy of bug hunt status so posted it here instead.

On my computer I have two accounts, my 'normal' admin account and my writing account. I have Scrivener set as a log-in item for the writing account. The last few versions have always loaded my current project when launching at log-in, however beta 4 no longer does this. If I open my current project then quit, it will correctly open it upon relaunching.

User avatar
KB
Site Admin
Posts: 19198
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Wed Nov 15, 2006 4:38 pm Post

Actually, I suppose it is a bug. :) I changed the code that Scrivener uses to open new projects so that it opens all the projects you last had opened during the last session rather than just the last one opened. I based this code on Mori's code for doing this, and in doing so I moved this code to the place where it is in Mori - but it turns out it was better off where I had it in the first place! So I have moved the code back to where it was before, which means that this will work again in beta 5.
Thanks,
Keith

da
dagaz
Posts: 130
Joined: Fri Jul 14, 2006 8:46 am
Location: Murwillumbah, Australia

Tue Dec 12, 2006 6:50 am Post

KB wrote:... this will work again in beta 5.


Just confirming, this now works again. Thanks heaps.

You know, I'm actually looking forward to the day when Scrivener turns 1.0 so that I can pay you some money for the incredible amount of work you've put into it!

Also, I feel kinda guilty when I'm enjoying writing in it so much when I know that you're concentrating on writing the actual program.

:lol: