Lost files.

An
Anysia
Posts: 11
Joined: Mon Nov 06, 2006 1:52 am

Thu Nov 09, 2006 11:45 pm Post

I think I managed to open my file with the wrong version of Scrivener (Gold) instead of the beta (I know, I know, both weren't supposed to be there). I lost one of the chapters for my Nano novel.

Is there any way to get it back?

Edit: Rescued it from a .txt file I had exported to do a wordcount *phew*. Still curious as to how this happened or if there is a way to fix it.
Last edited by Anysia on Thu Nov 09, 2006 11:54 pm, edited 1 time in total.

User avatar
KB
Site Admin
Posts: 19147
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Thu Nov 09, 2006 11:52 pm Post

In Finder, ctrl-click on the .scriv file and select "Show Package Contents". Your chapter should be one of the RTFD files contained inside the package.

Note that it is currently really dangerous to open a S1 file in SG - it will really screw up the project. I will release an updated version of SG that refuses to open S1 files soon, but I do really recommend that SG is wiped from your system if you are using the S1 betas... Yeah yeah, I know you've heard that before and that the real world doesn't work like that, so I will update SG soon. :) Hope you manage to find your chapter.

Thanks,
Keith

An
Anysia
Posts: 11
Joined: Mon Nov 06, 2006 1:52 am

Thu Nov 09, 2006 11:58 pm Post

[quote="KB"]In Finder, ctrl-click on the .scriv file and select "Show Package Contents". Your chapter should be one of the RTFD files contained inside the package.[/quote]

I knew there was a way to do that, but couldn't remember. As for opening in SG, I must have clicked on the file name and it opened SG (Also looking for how to fix that in my Mac settings). I know it's completely my fault, but it never hurts to ask if there is a cure for chair-keyboard interface problems.

Thanks. :D

cr
cruxdestruct
Posts: 117
Joined: Thu Sep 21, 2006 10:45 pm
Contact:

Fri Nov 10, 2006 12:44 am Post

Anysia wrote:
KB wrote: As for opening in SG, I must have clicked on the file name and it opened SG (Also looking for how to fix that in my Mac settings).


Get Info on a file, and change 'Open With...' to the program of your choosing. Then click 'Change All' to have that program open all files of that type.

An
Anysia
Posts: 11
Joined: Mon Nov 06, 2006 1:52 am

Fri Nov 10, 2006 1:35 am Post

Thanks, done (also erased SG just so I couldn't make that particular stupid mistake again). :wink: