Scrivener 1.11 public beta 3 now available (13/11/07)

RT
RTJK
Posts: 79
Joined: Sun May 13, 2007 9:57 pm
Location: UK

Sun Nov 18, 2007 9:32 pm Post

Don't know if this is helpful or not but Amber's label-colour-chip column issue isn't showing up for me in Tiger 10.4.10 or 10.4.11 - it's all working as normal.

I expect you'll be glad to hear I've had no problems with 1.11 b3 whatsoever after many hours of intensive use.

Thanks again for another great update.

Robin

(PS really excited to hear about the upcoming Final Draft integration tweaks - but I'm very happy with the app as it, is so take as long as you like.)

User avatar
KB
Site Admin
Posts: 19158
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Sun Nov 18, 2007 9:34 pm Post

Thanks - that is helpful. It means I definitely have to test on Tiger as well and tweak separately for both systems. The padding around the cell must have changed in Leopard so that it is smaller.

The Final Draft thing is going to take some time - it's a binary file format that I have to decipher, and I have no experience of such low-level formats...

Best,
Keith

User avatar
AmberV
Posts: 20584
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Sun Nov 18, 2007 9:48 pm Post

Aha! I found the necessary variable: Scrivener links must be present in the document you are editing for the bug to show up. Block cursor doesn't seem to impact it either way, which would have been my first guess.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
KB
Site Admin
Posts: 19158
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Sun Nov 18, 2007 10:29 pm Post

Hmm... Tried adding a Scrivener link to my document and still couldn't reproduce it...
Best,
Keith

User avatar
AmberV
Posts: 20584
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Mon Nov 19, 2007 1:30 am Post

Exact steps, this toggles the bug on and off like a switch for me:
  1. New document in Binder
  2. Type some gibberish, backspace, non-blinking cursor should be visible
  3. Add a few line breaks and then drop another document in on one of the lower lines to make a link
  4. Move the cursor back to the line where there is already text (using either keyboard or mouse), make sure you are at the end of the paragraph and backspace. Cursor should disappear.

That always does it for me. It looks like it is more sly than I thought. There are cases where it works and cases where it does not, all in the same session; seemingly random. The cursor can be at the end of the line or anywhere within it. It seems to always disappear when nothing is typed before backspacing on existing text---and when typing a few letters before backspacing, that is when it gets more random. It also seems more reliable in paragraphs after the link, than before the link, strangely.

Ugh: Further usage reveals it really doesn't have anything to do with the presence of links, as I've seen it happen in documents that are nothing but text. But it does seem to be conforming to the pattern I noticed. The last paragraph in the document does not have problems, so it might just be that adding a link in another paragraph and then going back to a prior one is what triggered it---the editing anything other than the final paragraph part. And while I have seen it happen in the middle of the paragraph, it definitely does seem to pop up much more reliably when the cursor is on the last column of the line.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
KB
Site Admin
Posts: 19158
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Mon Nov 19, 2007 4:27 pm Post

Okay... I see it. Thanks! I'm not 100% sure I'll be able to fix it given that this is already a hack, but I'll certainly take a look at it.
Best,
Keith

Do
Dom
Posts: 7
Joined: Fri Apr 13, 2007 5:50 pm
Location: Colchester, Essex

Tue Nov 20, 2007 11:44 am Post

Very minor thing: in Project Statistics the tick boxes to exclude footnotes and annotations actually seem to include them!

Jo
Jolanth Szatmary
Posts: 123
Joined: Sat Oct 06, 2007 9:58 am
Location: Cologne, Germany

Tue Nov 20, 2007 3:18 pm Post

One more thing:

In Compile Draft, alt-selecting check boxes (e.g. page break before) does not yet select / unselect all items as it doesm for instance, in outline view.

Note: this refers to 1.1., haven't dowloaded the latest beta yet as I've got major work in progress.

User avatar
KB
Site Admin
Posts: 19158
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Tue Nov 20, 2007 6:23 pm Post

Dom - you are right. Weird, and whoops.

Jolanth - no, it doesn't, and neither will it for the foreseeable future. There are technical reasons why it is more difficult to implement in a table such as the one in Compile Draft than in an outline view or a series of checkboxes elsewhere. It will probably get added in a future version, but not 1.1x.

Best,
Keith

sa
sampler
Posts: 71
Joined: Sat Oct 20, 2007 11:34 pm
Location: Hudson Valley, New York USA

Fri Nov 23, 2007 9:30 pm Post

OS X 10.4.11 PB G4 Scrivener 1.11beta3

I select 'Draft' or any other folder, Open Index Card Stack in Editor. The Outliner button next to the Cork Board button in the toolbar is bright, then dims and becomes non-responsive. Cmd-1 will not re-activate Outline View. Only clicking around in the outline pane restores the view.

There's nothing in the console log.

User avatar
KB
Site Admin
Posts: 19158
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Fri Nov 23, 2007 9:52 pm Post

Expected behaviour. Outliner isn't available during an arbitrary corkboard selection.
Thanks,
Keith

sa
sampler
Posts: 71
Joined: Sat Oct 20, 2007 11:34 pm
Location: Hudson Valley, New York USA

Sat Nov 24, 2007 2:42 am Post

Got it, Thanks. The outliner is available only for single folders or documents that can potentially have children.

Steve

User avatar
KB
Site Admin
Posts: 19158
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Sat Nov 24, 2007 11:44 am Post

Exactly - thanks for taking the time to post, though (sorry about my previous very short reply - I was typing it standing up as I was on my way to dinner :) ).
Best,
Keith

User avatar
Lord Lightning
Posts: 652
Joined: Fri Jun 23, 2006 4:58 am
Location: Somewhere else!

Sun Nov 25, 2007 6:10 am Post

Keith said;

I was typing it standing up


I seem to remember that Ernest Hemingway did the same thing.


:D
Lord Lightning

I'm a writer. I create worlds!
When I make a declarative statement it applies to ME. Not to everyone.

User avatar
KB
Site Admin
Posts: 19158
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Sat Dec 08, 2007 1:35 pm Post

Note that 1.11 is now out of beta and has become the official version:

http://www.literatureandlatte.com/forum ... 2674#22674

Bug reports can thus now be posted in the main forum area.

Thanks!
Keith