Scrivener 1.1 beta (1.07) public beta now available

User avatar
ptram
Posts: 951
Joined: Sun Mar 25, 2007 3:43 pm
Platform: Mac
Location: Recanati, Italy

Mon Jul 30, 2007 10:21 am Post

Keith, the Project Statistics also crashed to me, when I checked the "Include sub-documents" option with a rather big project. Please find my log, too.
Paolo
Attachments
scrivenercrash_pt.txt
Crashlog with Project Statistics
(3.34 KiB) Downloaded 135 times

User avatar
KB
Site Admin
Posts: 19158
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Mon Jul 30, 2007 1:49 pm Post

To avoid the project statistics crash, try turning off "No widows/orphans" in File > Page Setup > Settings... > Scrivener > Text Options.

Let me know if turning off that option fixes the crash for you. I know where the crash is happening but have no idea why. In fact, I have a sneaky suspicion (and evidence that I cannot share ;) ) that this is an OS X Tiger bug...

Best,
Keith

User avatar
ptram
Posts: 951
Joined: Sun Mar 25, 2007 3:43 pm
Platform: Mac
Location: Recanati, Italy

Mon Jul 30, 2007 1:54 pm Post

Keith, so it does. And, when turning on that Page Setup option again, the crash is no longer there. It seems that turning the Windows/Orphans option off and then on again fixes the bug.

Restarting Scrivener resets everything: the bug reappears, and is solved again as you suggested.

Paolo

User avatar
popcornflix
Posts: 203
Joined: Tue Feb 13, 2007 8:18 pm
Location: Row 15 Seat 107

Mon Jul 30, 2007 4:01 pm Post

Thanks for improving Scrivener's utility as a screenwriting program. Auto-complete looks very helpful, but I'm having some trouble getting it to work right.

When I make a new scene heading and type "IN," Scrivener automatically offers me a shortcut for "INT." (YAY!), and even adds a dash when I hit TAB after the setting. However, I can't seem to get it to offer me the shortcuts for DAY or NIGHT.

Typing doesn't seem to trigger it, and neither does option-esc or cmd-.

Is there a preference or other secret handshake that I need to set correctly?
.:popcornFlix:.

User avatar
KB
Site Admin
Posts: 19158
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Mon Jul 30, 2007 4:48 pm Post

DAY and NIGHT are there in the standard screenplay mode - just type "D" or "N" to trigger. If it's not working, go to Text > Scriptwriting > Script Settings... and check the Auto-Complete tab to ensure that they are in the list for the element for which you wish them to appear ("Scene Heading" is where they should be).

ptram - thanks for that. It's good to know that the widows/orphans fixes it for others, too, as it means that I do know where the bug is; fixing it is a different matter.

Best,
Keith

User avatar
popcornflix
Posts: 203
Joined: Tue Feb 13, 2007 8:18 pm
Location: Row 15 Seat 107

Mon Jul 30, 2007 5:32 pm Post

KB wrote:DAY and NIGHT are there in the standard screenplay mode - just type "D" or "N" to trigger. If it's not working, go to Text > Scriptwriting > Script Settings... and check the Auto-Complete tab to ensure that they are in the list for the element for which you wish them to appear ("Scene Heading" is where they should be).


Ah, well, perhaps this is a bug, then.

DAY and NIGHT are indeed listed in the Script Settings>Auto-Complete tab under "Scene Headings." When I try to use it, it works fine for the first Auto-complete (INT.), but then doesn't work for the second (DAY, NIGHT, etc). I can't make it work manually, either.


This is on a G4 PB with 10.4.5
.:popcornFlix:.

User avatar
KB
Site Admin
Posts: 19158
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Mon Jul 30, 2007 8:41 pm Post

Is there anything being logged in the Console.app (as required for beta testing :) )?

It all works for me.

Best,
Keith

User avatar
popcornflix
Posts: 203
Joined: Tue Feb 13, 2007 8:18 pm
Location: Row 15 Seat 107

Mon Jul 30, 2007 9:21 pm Post

KB wrote:Is there anything being logged in the Console.app?


Nope. When I type "D" or "N", Scrivener does nothing, and nothing appears in Console.

However, when I first start Scrivener, Console displays this:

2007-07-30 14:15:19.087 Scrivener[591] *** Illegal NSTableView data source (<SCRSearchResultsController: 0x4dee00>[object class: SCRBinderDocument, number of selected objects: 0]). Must implement numberOfRowsInTableView: and tableView:objectValueForTableColumn:row:
2007-07-30 14:15:26.920 Console[593] Can't open input server /Users/me/Library/InputManagers/Smart Crash Reports
.:popcornFlix:.

User avatar
KB
Site Admin
Posts: 19158
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Mon Jul 30, 2007 9:25 pm Post

That console message is harmless (and blast Apple for messing up and leaving it in there, as I have to explain this regularly :) ).

Could you please describe your EXACT process in trying to get the "Day" or "Night" auto-complete to work. If there is no error, this is unlikely to be a bug...

What happens when you click opt-Escape? Does a list appear at all? What have you actually typed when you pause and wait?

Best,
Keith

User avatar
ptram
Posts: 951
Joined: Sun Mar 25, 2007 3:43 pm
Platform: Mac
Location: Recanati, Italy

Mon Jul 30, 2007 10:49 pm Post

Trying to write INT. DAY in a Scene Heading. When typing "I", the pop-up menu appears, and you can choose INT. or INT./EXT. from it.

Then, type "N", "D" or "A" (for Night, Day or Afternoon, with or without a space before them), and nothing appears. Even pressing Cmd-. or Opt-Esc after the character.

Everything works fine when typing "M" or "E" (for Morning or Evening).

The last log I can see in the console.log is from this afternoon. Where could I read a more meaningful log?

Paolo

(Hint: It seems to me that the characters not working with the auto-complete menu, are the same used to choose the type of line, like D for Dialogue, or A for Action, from the menu in the lower-right corner.)

User avatar
popcornflix
Posts: 203
Joined: Tue Feb 13, 2007 8:18 pm
Location: Row 15 Seat 107

Mon Jul 30, 2007 11:50 pm Post

KB wrote:Could you please describe your EXACT process in trying to get the "Day" or "Night" auto-complete to work.


-Make new document
-Verify that it is set to Screenplay
-Verify that insertion point is in Scene Heading paragraph
-Type "I"
--Auto complete list pops up, offering I/E, INT. and other choices
-Use arrow key to select INT.
-Type RETURN to post INT.
-Type "FOREST"
-Type TAB
--Scrivener inserts a hyphen
-Type "D"
--Scrivener does not pop up Auto complete list.
-Type option-esc
--Scrivener does not pop up Auto complete list
-Type Cmd-period
--Scrivener does not pop up Auto complete list
--Console does not return any message


KB wrote:What happens when you click opt-Escape?


By "click," I assume you mean "type," as there is no mouse activity involved.

Nothing happens when I type opt-esc or cmd-. after "D"

KB wrote:Does a list appear at all?


Not at all.

KB wrote:What have you actually typed when you pause and wait?


INT. FOREST - D
.:popcornFlix:.

Ro
RobertB
Posts: 142
Joined: Sat Mar 31, 2007 5:36 pm
Platform: Mac

Tue Jul 31, 2007 5:01 am Post

I'm seeing this behavior as well. Autocomplete actually worked briefly but now it doesn't seem to work at all even when hitting cmd- - or opt - esc. Nothing is displayed in the console.

User avatar
KB
Site Admin
Posts: 19158
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Tue Jul 31, 2007 10:25 am Post

popcornflix - my sincerest apologies. I made the silly mistake of not double-checking this in Tiger before posting (I have to build on the Leopard beta in order to make sure it's compatible).

I have now recreated the problem and know what is causing it, though getting around it is going to be awkward.

Basically, this happens whenever the auto-completion list only returns one word. So, with "Night", "Day" etc, they are the only words in the list beginning with "N" or "D". The OS X text system does not display a list when there is only one word in it. If you type "E", the list returns both "Evening" and "Ext." - there is more than one word, so you get the list. If you type "EV", though, the list again will not appear because now there is only one word in the list - "Evening".

You can recreate this behaviour in TextEdit - try typing "Serend" and then hit opt-Escape. You will get a list of completions. Then try typing "Serendipitousl" and hit opt-Escape. The word will be completed, but there will be no list from which to choose because there can only be one - "Serendipitously".

That works fine in TextEdit because you have to call up the auto-completion list manually, and when you do the completion gets inserted into the text automatically. In the case of script elements, however, where the list gets presented automatically after a slight pause, you most certainly do not want the word to get inserted into the text automatically as deleting text and other edits suddenly gets horrible.

The easiest fix for this is if I add a blank item at the end of the list (a single space character) when the list would otherwise return only one item, so that is what I will do.

Thanks and all the best,
Keith

ma
matt
Posts: 1180
Joined: Mon Jul 30, 2007 9:35 am

Tue Jul 31, 2007 11:17 am Post

KB wrote:To avoid the project statistics crash, try turning off "No widows/orphans" in File > Page Setup > Settings... > Scrivener > Text Options.

Let me know if turning off that option fixes the crash for you. I know where the crash is happening but have no idea why. In fact, I have a sneaky suspicion (and evidence that I cannot share ;) ) that this is an OS X Tiger bug...

Best,
Keith


Keith,
Fixes for me also.

Matt

User avatar
KB
Site Admin
Posts: 19158
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Tue Jul 31, 2007 10:06 pm Post

I have spent days now on the widows and orphans bug and it's driving me crazy. What's worse is that I never intended to have a "widows and orphans" feature in the first place. Argh!

Best,
Keith