Beta Bugs - Post Them Here

User avatar
nontroppo
Posts: 755
Joined: Mon Mar 05, 2007 5:22 pm
Platform: Mac
Location: Airstrip One

Sun Oct 05, 2014 2:47 am Post

Thanks for all your hard, behind the scenes, OS apple bug battling. Indeed this joint iOS / OS X release timeframe makes little sense...

I often work in split view and resize, I notice the invisibles are sometimes lost but my text seems OK (rMBP). Not sure if that means its fixed or just I can't trigger that bug.

Will the page workaround affect the non-paged mode? As I still see quite a lot of performance issues (context menu speed and scrolling smoothness) in Yosemite, I hope the non-apple solution doesn't affect my normal view.

User avatar
nontroppo
Posts: 755
Joined: Mon Mar 05, 2007 5:22 pm
Platform: Mac
Location: Airstrip One

Tue Oct 07, 2014 2:25 am Post

I've been getting quite a few crashes mostly occuring during editing (including adding in various unicode characters from the character panel), and as I'm not online often as I'm travelling, they don't get sent to you so I've emailed them...

User avatar
nontroppo
Posts: 755
Joined: Mon Mar 05, 2007 5:22 pm
Platform: Mac
Location: Airstrip One

Tue Oct 07, 2014 2:42 am Post

I also notice these in console:

07/10/2014 10:14:35.193 Scrivener[7129]: WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.0 instead of 10.10.0. Use NSProcessInfo's operatingSystemVersion property to get correct system version number.
Call location:
07/10/2014 10:14:35.193 Scrivener[7129]: 0 CarbonCore 0x9830d7e7 ___Gestalt_SystemVersion_block_invoke + 135
07/10/2014 10:14:35.193 Scrivener[7129]: 1 libdispatch.dylib 0x91a34130 _dispatch_client_callout + 50
07/10/2014 10:14:35.193 Scrivener[7129]: 2 libdispatch.dylib 0x91a340b5 dispatch_once_f + 251
07/10/2014 10:14:35.193 Scrivener[7129]: 3 libdispatch.dylib 0x91a350d8 dispatch_once + 31
07/10/2014 10:14:35.193 Scrivener[7129]: 4 CarbonCore 0x9829ffb8 _Gestalt_SystemVersion + 1050
07/10/2014 10:14:35.194 Scrivener[7129]: 5 CarbonCore 0x9829fb69 Gestalt + 150
07/10/2014 10:14:35.194 Scrivener[7129]: 6 Scrivener 0x002dd05c Scrivener + 2998364


and

07/10/2014 10:14:38.023 Scrivener[7129]: NSSoftLinking - The ShareKit framework's library couldn't be loaded from /System/Library/PrivateFrameworks/ShareKit.framework/Versions/A/ShareKit.

User avatar
AmberV
Posts: 20613
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Tue Oct 07, 2014 5:11 am Post

The Gestalt bit should be fixed. We spotted that one a while back. ShareKit is going to be a bit of a known problem for a bit. Apple has yanked support for 32-bit on that framework, completely and without warning, so until Scrivener is 64-bit it can’t access it (that’s easier said that done). Consider this message normal for now, and unless you used the Twitter button, it will be no big deal.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
nontroppo
Posts: 755
Joined: Mon Mar 05, 2007 5:22 pm
Platform: Mac
Location: Airstrip One

Fri Oct 10, 2014 9:57 am Post

Hi, in my research folder, many files complain when I try to open them in the external app using the button on the bottom right of the editor:

Code: Select all

The file could not be opened.

There was a problem opening the file in the default viewer. Please try opening the file in a different program.


If I long press the menu shows the default app from the OS and if I select this default app, then it opens fine and after that I don't see the error again. In the scrivx XML this line gets added so scriv learns my choice:

Code: Select all

<PreferredExternalApplication>/Applications/Preview.app</PreferredExternalApplication>


Scrivener seems to know already what the default app is (it is top of the list in the menu), so why does it need me to "teach" it to use the default app. Not sure if this is a beta bug but I don't remember seeing it in older versions?

User avatar
nontroppo
Posts: 755
Joined: Mon Mar 05, 2007 5:22 pm
Platform: Mac
Location: Airstrip One

Fri Oct 10, 2014 10:15 am Post

Another problem, though again not sure if this is a beta problem or Yosemite PB5 problem, when using spotlight to select a .scriv file, the quicklook preview on the right fails to show, just shows the spinning wait animation. Using quicklook in Finder and the preview displays fine.

User avatar
KB
Site Admin
Posts: 19198
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Fri Oct 10, 2014 1:10 pm Post

Thanks! The Spotlight bug has to be a Yosemite problem, because if it's showing fine in the Finder, there is no reason that Quick Look can't show a preview for it and it shows that the preview is displaying correctly. I can reproduce the issue, though. My guess is that Spotlight's preview is broken with programs that provide their Quick Look preview inside the project file rather than as a system plugin (both methods are valid). I have reported the issue to Apple as bug ID #18609573, although I wouldn't expect Apple to fix any more bugs reported by developers until they put the next version of OS X (10.11) into beta - my experience is that once they reach the Golden Master stage, they leave all developer-reported bugs until the next major OS.

As for the Open in External Editor bug, that's something stupid I did in the code. Fortunately I read this just as I was pulling and re-uploading 2.6 to the Mac App Store, ready for release, so I've just managed to fix it in time.
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

User avatar
KB
Site Admin
Posts: 19198
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Fri Oct 10, 2014 6:54 pm Post

Also, nontroppo, I looked at your crash logs (thanks for sending them!) but they seem to indicate the the crash is coming from Apple's text view drawing methods. I haven't seen any other crashes like this myself, so I'm hoping this is something that will go away with a clean install of the release version of Yosemite (although I shouldn't be so hopeful seeing as that will almost certainly be identical to the Golden Master). Is this with all projects or just one in particular?
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

User avatar
nontroppo
Posts: 755
Joined: Mon Mar 05, 2007 5:22 pm
Platform: Mac
Location: Airstrip One

Sat Oct 11, 2014 1:30 am Post

I haven't seen it with other projects, but I'm currently mostly in one project so perhaps that is just sampling bias!

Is 2.6 the fruit of the 2.5.5 beta?

User avatar
KB
Site Admin
Posts: 19198
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Wed Oct 15, 2014 8:05 pm Post

Is 2.6 the fruit of the 2.5.5 beta?


It is, yes. And apologies for not getting back to you on various things this week - I've had hell with the Mac App Store (code-signing crashes) and have been trying to get 2.6 up and out before Yosemite's (rumoured) release tomorrow. 2.6 is now out, so we we can continue to troubleshoot with that. I'll reply to everything else by the end of the week.

Thanks again!
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

Be
Benjamine
Posts: 27
Joined: Wed Aug 01, 2012 8:13 pm
Platform: Mac

Tue Sep 22, 2015 11:43 pm Post

Slightly odd one for build 26067: smart quotes randomly stop working in the main editor. They start working again if I restart Scrivener.

I am running scrivener on El Capitan, by the way.

User avatar
KB
Site Admin
Posts: 19198
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Wed Sep 23, 2015 9:16 am Post

Benjamine wrote:Slightly odd one for build 26067: smart quotes randomly stop working in the main editor. They start working again if I restart Scrivener.

I am running scrivener on El Capitan, by the way.


Are you using page layout view? If so, this is an intermittent bug that has been plaguing Scrivener for a couple of years. It only seems to affect some users, strangely. However, I *think* I have a fix for it, but it hasn't made it into 2.7 because it involves a bit an architectural change under the hood, and I want to do a lot more testing on it to ensure it doesn't cause other problems before releasing it into the wild.
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

ma
marcoiac
Posts: 392
Joined: Mon Aug 29, 2011 12:12 am
Platform: Mac

Mon Sep 28, 2015 10:08 am Post

I forget: is beta 2.6.5 (which I am running) same as official release 2.7? I am seeing all these threads on 2.7 and I don't get the prompt to update from 2.6.5

User avatar
KB
Site Admin
Posts: 19198
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Mon Sep 28, 2015 12:37 pm Post

It is pretty much the same, but I would update as there a few last-minute bug-fixes. I think the automatic updater might be confused by the 2.6.5 vs 2.70 version numbering. I had to start using a stupid version numbering system as of 2.6 because the Mac App Store won't let you upload builds with the same version number. So, if you upload version 2.6 and Apple rejects it, you can't resubmit a version 2.6; you have to submit 2.6.1. But because I use those third point numbers as maintenance releases if necessary, I didn't want to use them up just submitting different builds to the MAS for the review process, so I adopted the numbering system 2.60.1, 2.60.2 for App Store review builds. It's all very silly, but that's the App Store review process in general. (And after all the hoops they put developers through, they still don't catch genuine security risks.)
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

ma
marcoiac
Posts: 392
Joined: Mon Aug 29, 2011 12:12 am
Platform: Mac

Mon Sep 28, 2015 2:15 pm Post

The problem is that my 2.6.5 has the 'check for updates' greyed out. can't figure out how to update. funny thing is i thought i downloaded the beta on both laptops, but one laptop is happily running 2.7, so it automatically updated. i guess i just downloaded the beta on one laptop? that doesn't sound right though, i should have noticed the different icons. regardless, how do i get 2.7 now from 2.6.5? this is not a MAS app, I got it from L&L directly

 

 

cron