eSellerate in latest Scrivener Beta

User avatar
Merovech
Posts: 94
Joined: Thu Jun 02, 2011 2:54 am
Platform: Mac
Location: Virginia, USA
Contact:

Thu Dec 20, 2012 12:22 am Post

I tried to install today's beta. I received an eSellerate error (-2003). I followed the fix-it information and deleted the MindVision directory. Still broken. I did not go beyond.

Regular Scrivener works just fine, but having deleted the MindVision directory it had to re-activate for my computer.

So, the problem is not the permissions.

User avatar
KB
Site Admin
Posts: 19198
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Thu Dec 20, 2012 9:32 am Post

Jennifer had this, too, and I believe she is chasing it up with eSellerate. I've tested it on a couple of computers and have had no problems, and Ioa has done the same, so it must be computer-specific. The new update incorporates an update to the eSellerate framework, so it will try to install this eSellerate update. For some reason, it seems that on your machine, it is refusing to allow eSellerate to update. I'll ask Jennifer to post back here after she has spoken to eSellerate.

Out of interest, is this on an admin or non-admin account?

(Incidentally, this should be posted in the Beta forums seeing as it is related to the current beta and not the release version.)
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

User avatar
johnz
Posts: 81
Joined: Thu May 24, 2007 4:11 pm
Platform: Mac
Location: Italy

Thu Dec 20, 2012 9:57 am Post

Hi Keith,

Same problem here, eSellerate error 2003; I went through the Fix instructions on Base knowledge page, and nothing worked - I've sent a mail to the address in the page with the "Stats.txt" file attached. Still my Scrivener copy it's in "Try" version, unable to identify my license number.

Sorry for posting here, but I saw the post topic and thought, I'm not the only with this problem :shock:

Waiting (without panic) for help...

Giovanni

User avatar
KB
Site Admin
Posts: 19198
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Thu Dec 20, 2012 10:18 am Post

Remember that you can roll back to the release version if you can't open Scrivener at all. -2003 just means that there was an error installing the eSellerate engine. Jennifer has emailed eSellerate, so hopefully we'll have some news before the holidays. :)
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

Ta
Tacitus
Posts: 170
Joined: Sun Jun 17, 2007 10:33 am
Platform: Mac
Location: UK

Thu Dec 20, 2012 3:34 pm Post

I've just installed the beta in my user account and get the same problem. However if instead of clicking fix you just click OK when the error msg appears, Scrivener then loads in trial mode.

I'm guessing the beta will expire prior to the expiration of the trial period by which time the problem may be resolved.
History is a nightmare from which I am trying to escape

User avatar
KB
Site Admin
Posts: 19198
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Thu Dec 20, 2012 4:10 pm Post

Guys, I'm off on holiday tomorrow for two weeks, so it's unlikely this is going to be resolved for another fortnight. If it's stopping you from working, please revert to the non-beta version. Jennifer will post back here when she hears back from eSellerate.

I would definitely check the permissions on your user accounts as specified in the "Fix" information, if you haven't already.

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

User avatar
johnz
Posts: 81
Joined: Thu May 24, 2007 4:11 pm
Platform: Mac
Location: Italy

Thu Dec 20, 2012 4:27 pm Post

I have checked ALL permissions with Disk Utility and Onyx, I don't know if there are other steps to go in order to do this... As Tacitus said, I've got Scrivener working in trial mode (22 days remaining) - just in case, to re-install the 'official' release version, we need only to download and replace last beta? Just in case, you know 8)

Thanks, and enjoy your holidays Keith (and Ioa, David and all the L&L gang).

All the best,
Giovanni

User avatar
MimeticMouton
Posts: 8373
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Thu Dec 20, 2012 5:16 pm Post

Yes, just reinstalling the previous beta or the official release will get you running again; if you've tried fixing the permissions by following the steps on our support page, Scrivener will need to re-activate when you do this, but that should just take a second and then you'll be off and running. I've contacted eSellerate support for help with this issue and will let you all know what I hear back when we get this resolved.
Jennifer Hughes
(MM for short)

User avatar
MimeticMouton
Posts: 8373
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Thu Dec 20, 2012 8:02 pm Post

OK, troops, to fix the eSellerate permissions, please try the following:

1. Uninstall the latest Scrivener beta (build 21968) by dragging it from your Applications folder to the Trash

2. In the Finder, browse to the system level /Library/Frameworks folder (i.e. not the one in your home folder but the one you access by clicking on the main hard drive in the top of the left-hand source list in the Finder).

3. Delete the item named EWSMac.framework from the Frameworks folder by dragging it to your Trash and then emptying the Trash.

4. Go to ~/Library/Frameworks and delete the EWSMac.framework file from there (on Lion and up, the user Library is hidden; you can navigate to it by opening the Go menu and holding the Option key, then select "Library" when it appears in the menu)

5. Reinstall the Scrivener beta

Let us know if you're still having trouble after those steps, but hopefully that will resolve the issue and get you running with the new beta.
Jennifer Hughes
(MM for short)

User avatar
robertdguthrie
Posts: 3075
Joined: Mon Nov 09, 2009 10:06 pm
Platform: Mac
Location: St. Louis, MO, USA
Contact:

Thu Dec 20, 2012 8:10 pm Post

MimeticMouton wrote:4. Go to ~/Library/Frameworks and delete the EWSMac.framework file from there (on Lion and up, the user Library is hidden; you can navigate to it by opening the View menu and holding the Option key, then select "Library" when it appears in the menu)
.

Minor correction for Mtn Lion, at least: It's the Go menu where the Library appears when you hold down option.
Often wrong, rarely in doubt.
Time for a change... I'm now rdale; same dog-avatar, same dog... channel?

User avatar
MimeticMouton
Posts: 8373
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Thu Dec 20, 2012 8:23 pm Post

Bah, right you are. Fixed that.
Jennifer Hughes
(MM for short)

User avatar
johnz
Posts: 81
Joined: Thu May 24, 2007 4:11 pm
Platform: Mac
Location: Italy

Fri Dec 21, 2012 5:55 pm Post

Hi,

I followed these steps, reinstalled Scrivener (build 21968) and I'm now working just as usual, no more eSellerate errors.

Many thanks, guys (and girls :-) )

And Merry Christmas & Happy New Year / Buon Natale & Buon Anno!

Giovanni

De
DedeK
Posts: 1
Joined: Sun Nov 23, 2008 7:44 am

Sun Dec 23, 2012 4:46 pm Post

Worked fine on both of my Macs. Many thanks!

ds
dspady
Posts: 94
Joined: Thu Sep 16, 2010 12:29 pm

Mon Dec 31, 2012 2:59 am Post

I'm just going to stick with the standard Scrivener for now. I have no pressing need for anything fancier and will wait till the 'revised standard' version comes out.

At any rate, thanks for the directions to correct it, if I change my mind.

Happy New Year to all

Don

User avatar
KB
Site Admin
Posts: 19198
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Tue Jan 01, 2013 11:52 am Post

Hi Don,

You'll have the same problem in the standard version when the update is released, so you'll need to fix it sooner or later anyway.

Happy New Year!
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."