what happened to my snapshots?

on
oneworld9
Posts: 26
Joined: Thu Feb 22, 2007 8:17 am
Contact:

Thu May 10, 2007 8:44 pm Post

public beta 1.04 is a huge amount of work. It seems unbefitting for it to earn a measley tenth of a decimal. I am very happy with many of these changes, some of which i had resigned myself to never seeing.

Two points to share, however. In trying to upgrade i followed the usual steps of dropping the app file to my applications folder, thereby being prompted to overwrite the old. In doing so, i kept getting this error msg:

An error occured.

Mac OS error -8081
File is busy


src: /Users/michael/Desktop/Scrivener 1.1.04 Beta/Scrivener.app
desc: /Applications/Scrivener.app
item: /Users/michael/Desktop/Scrivener 1.1.04 Beta/Scrivener.app


I tried redownloading the zip file, logging out, ensuring no scrivener processes were running. In the end, the only way around this seemed to have been to delete the older scrivener app file. and then just drop the new one in.

I don't imagine this is related, but perhaps. Upon trying the new beta out, i was greatly disheartened to find that all of my snapshots for every single document were lost. If i prompt to show snapshots the window comes up blank. Is there any way to recover these snapshots? is this a bug in the project upgrade process, incompatibilities with old and new formats of snapshots, a result of my having to delete the app file, or something else?

User avatar
AmberV
Posts: 20584
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Thu May 10, 2007 9:05 pm Post

I have come across that error before when dragging upgrades into the Applications folder. I am not sure what causes it, and like you, the only way I've found to circumvent it is to delete the original (which never seems to have any "busy file" errors), and then drag the new version in. This is an OS X bug.

On to snapshots. I would try using the backup version of your project that Scrivener created, and try updating the project again. I have all snapshots intact in the one project I have tested 1.04 with. If they come up broken again there must be some circumstance in your project that is causing a reproduceable error.

If you go inside the project bundle, and look in the snapshots folder, is anything there?
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
KB
Site Admin
Posts: 19158
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Thu May 10, 2007 9:10 pm Post

Please keep bug reports inside the main beta thread rather than starting new topics within the forum - I don't want this forum to get cluttered.

I'm not sure why you had problems copying the file, though clearly that is nothing to do with Scrivener itself and just something that was going on in your system at the time.

I don't imagine this is related, but perhaps. Upon trying the new beta out, i was greatly disheartened to find that all of my snapshots for every single document were lost. If i prompt to show snapshots the window comes up blank. Is there any way to recover these snapshots? is this a bug in the project upgrade process, incompatibilities with old and new formats of snapshots, a result of my having to delete the app file, or something else?


This shouldn't be happening. The upgrade process should update all of your snapshot files. Are you sure it is opening successfully in 1.04 and not an older version? 1.04 looks quite different, as the header bar of the editor is now a gradient and the split view that separates the binder from the editor is a single pixel, like in Mail. If the interface is still the same as 1.03, then you have just opened your project up in 1.03. If this isn't the case, please send me both your updated project, and the back up made of it (so that I can test updating it myself to see what happens to the snapshots during the update process).

Best,
Keith

on
oneworld9
Posts: 26
Joined: Thu Feb 22, 2007 8:17 am
Contact:

Thu May 10, 2007 9:15 pm Post

how do i go about nominating you for a 'genius' award. You are so systematic in problem-solving. Sure enough resorting to the backup file and letting scriv re-update the file successfully kept the snapshots.

as always, many kind thanks, Amber.

User avatar
AmberV
Posts: 20584
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Thu May 10, 2007 9:32 pm Post

No problem!
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

da
dafu
Posts: 555
Joined: Tue Jan 30, 2007 1:33 am
Platform: Mac
Location: Chicago
Contact:

Thu May 10, 2007 10:05 pm Post

My guess about the file is busy report is the mdimport plugin (or whatever it's called). I discovered the same problem with Curio: you couldn't overwrite the old Curio with the new, you had to delete the old before moving in the new. We narrowed it down to spotlight.

Dave

User avatar
KB
Site Admin
Posts: 19158
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Thu May 10, 2007 10:09 pm Post

Dafu - yes, you are right! I forgot all about that. Yes, the spotlight plugin causes this error and that is why you need to delete the app first. It is an OS X bug, as Amber says.
Best,
Keith