2.0.5.5 - Post Bugs Here

User avatar
nontroppo
Posts: 733
Joined: Mon Mar 05, 2007 5:22 pm
Platform: Mac
Location: Airstrip One

Mon Jun 25, 2012 9:56 pm Post

Another buglet in 18217: when I try to open a PDF using the external editor icon in the status bar, I get the following even though Preview does successfully open the PDF:

Code: Select all

The file could not be opened.

There was a problem opening the file in the program "(null)". Please try opening the file in a different program, or ensure that (null) is installed properly

User avatar
AmberV
Posts: 20570
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Mon Jun 25, 2012 10:11 pm Post

What is your OS X version?
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
KB
Site Admin
Posts: 19142
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Tue Jun 26, 2012 6:04 pm Post

Although the message has a bug in it (it shouldn't say "(null)"), this means that there was no default application set up to open this file type, or, at least, that OS X didn't return it correctly: if there is no application associated with the file type within Scrivener's settings, then it just calls on OS X to open the file in whatever application it chooses. It's strange it isn't working, though. Is this opening with all PDF files, or only one? What happens when you export those PDF files and double-click on them in the Finder?

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

User avatar
nontroppo
Posts: 733
Joined: Mon Mar 05, 2007 5:22 pm
Platform: Mac
Location: Airstrip One

Tue Jun 26, 2012 11:37 pm Post

Sorry I may not have been clear, even though I get the error requester (and bouncing Scrivener dock icon warning), Preview does still open the PDF from Scrivener. It happens to all of my PDFs tested so far.

If I export the PDF from Scrivener, then it is shown to open with Preview (⌘i Get Info) and does open without problem on double-click. Preview is the default app for PDFs — i.e. I haven't changed it.

I do have a second Lion partition, and LaunchServices has the other Preview indexed in its list, but Finder has no problems opening with the correct Preview.

This is all on OS X 10.7.4.

se
sero
Posts: 27
Joined: Sat Jan 29, 2011 10:42 am
Platform: Mac

Tue Jun 26, 2012 11:42 pm Post

nontroppo wrote:Another buglet in 18217: when I try to open a PDF using the external editor icon in the status bar, I get the following even though Preview does successfully open the PDF:

Code: Select all

The file could not be opened.

There was a problem opening the file in the program "(null)". Please try opening the file in a different program, or ensure that (null) is installed properly


I can reproduce this bug here. I run Mountain Lion Developer Preview 4. I can try to reproduce it under 10.7.4 tomorrow, if this helps.

I have a possibly related problem: I can Quick Look pdf and other documents from the Reference pane just fine, as long as I am not in fullscreen composition mode. When I try the Quick Look the same files in composition mode (context-click on the file icon in the Reference pane --> Open in Quick Look) I only get an empty Quick Look window with the text "no items selected" in it. EDIT: I have this problem on OS X 10.7.4 with the stable Scrivener release, too. Am I doing something wrong here?

User avatar
KB
Site Admin
Posts: 19142
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Wed Jun 27, 2012 9:49 am Post

Ah, okay, this was just a bug in that last beta, which has been fixed for the next update (or rather, for the official 2.3 release, which is later today).

As for QL not working in Compose mode, gah, that's a stupid QL bug - as soon as the QL panel is opened, it switches focus to the main window for no good reason, into the text view, and by default text views are set to act as QL controllers and thus it returns nothing. I've worked around it so this should be fixed too for 2.3.

Thanks!

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

se
sero
Posts: 27
Joined: Sat Jan 29, 2011 10:42 am
Platform: Mac

Wed Jun 27, 2012 12:24 pm Post

Keith, you are my hero. Half of my rather lengthy support email is already obsolete now :D Let's hope this 2.3 release arrives very soon ;) EDIT: I can confirm that the problems are fixed in the final 2.3 release. Thanks again.

User avatar
nontroppo
Posts: 733
Joined: Mon Mar 05, 2007 5:22 pm
Platform: Mac
Location: Airstrip One

Thu Jun 28, 2012 10:37 am Post

Can confirm fixes work here too, thanks with cherries on top!

User avatar
KB
Site Admin
Posts: 19142
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Thu Jun 28, 2012 10:39 am Post

Thanks. And sero, you should have noticed that your other request made it into 2.3, too - you can now remove .tex as an importable type from the Plain Text Import Types preferences.
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."